Dorico Elements 3.5 - Clef Crisis

I am new to Dorico Elements. I have successfully created a project with multiple flows to keep separate movements (of a suite). Every movement has the same parts and instruments (by intention). I imported xml files into each flow. All is mostly OK except one of the instruments has the wrong clef? How can I change its clef for that flow alone? I have looked for several hours at how to fix this. I suppose I might, in desperation export to MuseScore edit and re-import but I’d rather prefer to get to the bottom of the problem.

Clefs are in the right panel of Write mode. Or you can select whatever’s on the first downbeat of that stave and type Shift-C treble Enter or Shift-C bass Enter or Shift-C alto Enter (etc.).

As to “getting to the bottom of the problem”, where’s the MusicXML file coming from? Is the clef correct in whatever program generated the MusicXML?

Thank you for your attention. I had previously looked at what you suggest but it seems superficial. It inserts by overlay a new clef symbol which can be subsequently deleted/replaced while the underlying clef cannot be deleted in this way. There are evidently two ways to set the clef and I’d like to ensure that in all flows for the part-instrument the clef is always the same.

Can you Change the Instrument in Elements? (Setup mode)


Adding a clef in Write mode is an override for the global instrument definition.

Try changing the instrument from the left panel of Setup mode. You’ll need to click the disclosure arrow to the left of the player to reveal the instrument, then hover over the instrument until you see a further disclosure arrow to the right. Click on that and go Change Instrument. Then search for whatever the instrument should be.

(edit; pipped to the post by @benwiggy)

I can change instruments but then I end up with multiple instruments in the part and a lack of consistency with other flows.

In terms of getting to the bottom of the problem, though, this is the problem.

When you import MusicXML in, you sometimes end up with instrument definitions that don’t match Dorico’s own instrument definitions. In addition to the clef issue, you may also find - if this Soprano is supposed to be a singer - that dynamics don’t automatically go above the staff, for instance. This is the sort of thing that Dorico gets right automatically if it knows that “Soprano” is a voice. If it thinks it’s e.g. a soprano sax, it’s going to get it wrong.

(And I realise that’s Ben’s screenshot so you may not have a soprano at all - the underlying point still stands though!)

The solution is to change your instruments, preferably for all of them - it’ll save you time down the line.

??? It should just replace the existing instrument. Or create a new player/instrument and paste the music in, then delete the old one.

Yes this works. It is quite time-consuming as I need to repeat this for all 20 flows in my work. Anyway I’ll do it and get on with my project.

It would be so much easier if there were the notion of a default clef for an instrument assigned to a part and then a way of enforcing the default.

To planoleo. I will create a replica of this project and try reimporting XML with a suitable clef in the XML. I’ll report back. Again my thought is that a default such as described above is really called for. (Maybe it exists in ‘Pro’ where overrides are discussed but that is not a product I can justify buying).

Once agin thank you both for your kindly help.

Wait a sec - do you have a separate instrument for each player for each flow? If so, you may find it less laborious to merge them all together. It’ll require assigning all players to all flows (which you can do from setup mode relatively quickly), and then quite a lot of cutting and pasting in Galley View - which is quicker once you know that Edit > Select to End of Flow is a thing.

Do you have different Players for each Flow? When you import the XML, there is an option to use the existing players. Otherwise, it will just keep adding new players.

If you’ve got the same player for each flow, then things will be a lot simpler. Also, there’s a limit to the number of Players in Elements.

Ah, no. I do have the same part and instrument combination for each flow. The problem is that in one flow the instrument presents itself in the bass rather than treble clef. In all other flows the instrument correctly presents in the treble clef. This is what has been troubling me.

Ah. Are you able to select and delete that clef at bar 1 in that flow?

The original root of my problem might lay here but I have since spent a lot of time ensuring that there are exactly two players in the project and each player has exactly one instrument. All is well except in one particular flow (flow number 11 as it happens) where one instrument uses a bass clef rather than treble clef.

As an experiment I temporarily added an Alto Trombone instrument to the offending part. Moved the noted to it and back again and the bass clef problem persists.

No I cannot select and delete. But I can overlay it with a treble clef - which itself can be selected and deleted to re-expose the offending bass clef.

I do appreciate your patience with me.

And changing the instrument, as Ben suggested near the top of the thread, doesn’t alter anything?
To be clear, I mean changing the existing instrument to what it already appears to be, from Setup mode, not creating a new instrument and cutting and pasting material.

I just changed the instrument to an Alto Trombone. Now flow 11 shows the Alto Clef (correct) and all other flows are still in treble clef!

There is some kind of hidden clef override going on - it seems to me.

Are the clefs at the starts of the other flows selectable and deletable?

No. All staves are unselectable in write mode.

I meant clefs

If you can Save As a new file, delete anything that’s confidential then upload the resulting file, I’m sure someone will be able to take a look and figure out what’s going on (though possibly not me - I’m out of the house shortly).