Dorico Elements 4.2 doesn't work with NotePerformer 3.3.2

So I’m new to Dorico and trying to use noteperformer as playback. I skipped the installation of HSSE and Sound Content when I installed Dorico. Now what I got is that noteperformer loads up on the starting screen, but it doesn’t show up in playback template. Although it does show up under VST instrument, playback has no sound at all. Any idea?

Welcome to the forum, @amadeus1994. Did you install NotePerformer before or after installing Dorico? If you installed it before, it might be worth running the NotePerformer installer again, as I have a feeling it might not install the necessary playback templates etc. unless it detects that Dorico is installed.

I reinstalled NotePerformer after Dorico, and I checked those template files and expression maps are there.

Thanks for confirming. Could you please do Help > Create Diagnostic Report and upload the resulting zip file so I can take a look and see whether I can spot anything within that might explain what you’re seeing?

I just got a new MacBook. I migrated my files from my previous computer (also a macbook). I registered Dorico opened a file and Noteperformer is not working. I went ahead and reinstalled Noteperformer and it still doesn’t work.

Hi @compoczar , please load a project which uses NotePerformer and then choose from the menu Help > Create Diagnostics Report. The resulting zip file then attach to a reply here. Thanks

Is your new Mac have ARM Chip or INTEL?
You probably need to run Dorico in Rosetta mode…Command+I to go to get info and click on Run Dorico in Rosetta Mode.

There we go. I’m on a MacBook Air M2. Easy fix, thanks friend!

No problem hopefully they update it to arm soon
Dorico is super fast on arm machine.

Hello Daniel,

Here is the diagnosis. :slight_smile:
Dorico Diagnostics.zip (261.0 KB)

Everything looks OK according to your logs. I guess the issue is probably that no appropriate output port has been found for Dorico to play back through. Have you tried following the playback troubleshooting advice in our video on the topic? You can find it, together with a transcript of said video a couple of posts later (should you find that useful), in this thread:

Problem solved. Didn’t configure the output device to my speakers :slight_smile: