Dorico expression maps: beginner still has questions

I’m fairly new to Dorico Elements 5 (which I like much bettter than the notation software I came from). I’ve watched some training and read some posts on expression, but still have a few pretty basic questions. Using Iconica Sketch.

  1. In a new project:
    If I add “Single player : Strings : Violin”
  • I get a new staff “Violin”
  • in HALion I see GM Violin
  • expression map is CC11
    If instead I add “Section player : Strings : Violin”
  • I get a new staff “Violin”
  • in HALion I see “Violins 1”
  • expression map is “Iconica Sketch Vlns…”
    The second is what I really wanted. I imagine that this is the expected behavior. I guess I was a little surprised/confused that “Violin” appeared in menu and score in both cases…
  1. Expression marks in the score obviously affect MIDI CC and keyswitches. But I can also draw in Dynamics in the expression editor (i.e. phrasing), without score markings. Can both of these coexist, or should score markings always be used? I’m not an expert engraver.

  2. I have set Init in the expression map to D#0 Sustain. I’ve drawn in some CC1 dynamics in the editor and they work as expected. If I add quarter notes with staccato markings, I don’t notice any keyswitches being activated. Maybe my manual editing interfered (question #2), or maybe there is a deeper level of expression that I don’t understand (it is pretty complex)?

I hope it is clear, and not too basic. Thanks in advance.

  1. There is no solo violin patch in Iconica Sketch, only section violins, so Dorico has to use GM Halion for the solo.
  2. Both score markings and drawn changes can coexist.
  3. There’s no real need to use Init in the expression map. Dorico will use the Natural keyswitch in the absence of any other instruction. (Expression maps only work with notations - playing techniques - marked in the score. They ensure the correct instructions are sent to a VST to trigger the effect you want to sound)
1 Like

To add to Janus’ answer
Playback Options → Timing → Note duration
Maximum duration for staccato [ something something ]

I get bit by this regularly.

1 Like

Thanks to @Janus and @derAbgang
I did notice in the expression editor that a “Natural” technique block was above the entire contents. And maybe I understand better how the rules are being applied.

The 2 entries after Init are based on note length - I guess they are being applied first.
I finally found the Timing option (control-shift-P). Timing indicated “maximum duration for staccato = quarter note (crotchet)”. If I change my quarter notes to eighths, I see the techniques change to Staccato in the expression editor. I guess notes with exactly the “maximum duration” will not be staccato (or maybe I misunderstand that option).

No. The list is alphabetic. They are just different switches that depend on the note length. So different CC/keyswitch will be sent if Legato (slur) is encountered with shorter notes. (Note length is determined by a combination of note duration and prevailing tempo).

1 Like

Just uncheck the option and every duration will show staccato in the key editor.

1 Like