Dorico file not opening (stuck at 92%)

Help! I cannot open any files anymore in Dorico 4.2. They are trying to open but get stuck at 92%. I have Dorico 3.5 alongside and happily I can still work on my files there.
Strange thing: I can start Dorico 4.2 and create a new file. But when saving and reopening: again, stuck at 92%…

Then the audio engine is crashing. Please do in Dorico from the menu Help >Create Diagnostics Report and post the corresponding zip file here. It will contain crash files which will tell me more.

Dorico (1.6 MB)
Thanks for looking into this!

Thanks for the data, but there are no crash files contained, only some HANG files, which are process dumps if the OS detect a process to be hanging. So first I thought it must be the audio engine but the logs do suggest that it is on Dorico’s side. So I’ve asked Daniel to take a look, he will come back soon.

Thanks! A very strange thing (maybe helpful to know); I tried to change the preferences and with these settings my file can be opened again…
Does it make sense? (at the moment: Logic is also open? maybe that helps?)
(thanks for forwarding this to Daniel!)

Thanks for the diagnostics, which I’ve taken a look at. It appears that the Dorico process is indeed hanging when trying to complete the loading of the project file. I think it’s at the point at which the saved plug-in state is sent over to the audio engine.

What is the nature of the configuration change you’ve made in the CoreAudio Device Settings dialog that allows the projects to open?

I just unchecked the ‘output’ (resulting in having no playback device of course). And also unchecked the Enable Asio Guard.
But I have no idea if I did something that makes sense?

I can’t imagine how the output port setting should have an impact on the project loading, however, the ASIO-Guard setting potentially can. So please try and switch that back on and see if loading gets stuck again. Thanks

Hi! I have totally no clue, but I checked the ASIO-Guard box again and suddenly after closing and restarting Dorico 4 I could choose my audio device again and after closing and restarting I opened the latest file I was working on and… no problems! And it plays back well also!
Maybe I have done something else that I’m not aware of but I really don’t know what… So really mysterious. But very happy Dorico 4 user again :-)))) (and happily haven’t lost time because I could work further in 3.5).
Anyways; many thanks for advising and guiding me. You are the software company with the VERY BEST support I have encountered so far!!

Sadly Dorico 4 doesn’t allow to open any file again (ASIO-Guard, VST plugins blocked/allowed, opening with sound device on/off, …). I tried all combinations. :frowning:
So it remains a mystery.
So now… back working in 3.5… :frowning:

Dorico 4 allows to create a new file (with setup). But saving and re-opening (after closing) does not work.

Sorry to hear you are back in trouble.
So please do it again and when Dorico is stuck, please open the Activity Monitor. Then search for and highlight the VSTAudioEngine process and click on the little i-icon at the top of the Activity Monitor and from the pop-up menu choose “Sampe Process” . Follow the on-screen instructions and post the resulting file to a reply here. Would be even better, if you could do this 2 times in a row. And when you did that for the audio engine process, please do the same for the Dorico process as well. Thanks a lot

Hi! I hope you can see something in attached files? (is that enough like this? or do both processes 2 times?)
Thanks! (70.0 KB)

Thanks for the data, I need to discuss this with Daniel. There is no obvious reason for the hanging, but from my perspective it is rather on Dorico’s side than the audio engine, but let’s see. We will come back soon.

And since this afternoon, everything works again… I really don’t know why…
Super strange behaviour.

Are any details of your system or network configuration changing over time? Do you have network-attached drives that are sometimes available and sometimes not?

No… and what I also noticed: no playback sound in 3.5 either…
And at the moment: still no success with Dorico 4. Won’t open any files. Still stuck at 92%

And when I start with a new file: I can do everything but also no playback. When I save and want to re-open that file: no success…

Can you please create a new diagnostics report? Thanks

Dorico (2.0 MB)
(Just managed to open one file. But no playback.)

Were you able to identify the issue that caused this? I am dealing with this right now - stuck at 92% - just finishing a very large project and I’d rather not have to create the parts and scores in 3.5

and now it suddenly works… :man_shrugging:t4: