Dorico/Halion Sonic SE Playback Issues

Hi - I purchased Dorico Elements a couple months ago, and overall I’m very happy with the purchase. However, I’ve had a consistent problem with sound playback using the Halion Sonic SE plugin that I’ve been unable to resolve on my own. When I first open a Dorico file, playback works fine - I can select the first note of the piece, hit ‘p’ and it will playback correctly. However, the longer I leave Dorico open and/or the more notes I input, the more playback degrades.

The ‘degradation’ effect that I observe is a shortening of note lengths - notes will gradually become more staccato (and in some cases more poorly timed) until the notes are so short that they no longer play back at all. This is particularly problematic in places where I have a piano pedal line. Rather than sustaining the notes through the pedal line, each note will sound as a staccato.

The problem does not affect sounds created by note entry (i.e. when I touch a key on my MIDI controller), only the sounds from playback of notes already entered. Also, the more players and MIDI channels I have in a piece, the faster this degradation seems to occur. I have one piece with a piano, an SATB reduced score, and multiple individual staffs for other voice parts, and after opening this piece it’s typically less than 5 minutes before the playback quality degrades to the point of being unusable.

Has anyone ever encountered this before?

Here are my system specs:
Intel Core i7-7700K
32 Gb RAM
Sound Card: Creative Sound Blaster Zx
Windows 10 version 1903
Dorico Version:
Halion Sonic SE Version: 3.3.0

I’ve never heard anything along the line what you describe. Under Edit > Device Setup, what driver is selected and what sample rate? And even more important, what audio block size is the driver set to. For that info you have to push the ‘Device Control Panel’ button, though what you describe it actually can’t have anything to do with, still I want to know.
And would it be possible that you provide that project, so that I can see if I can reproduce it on my machine? If you don’t want to attach it here, could you please send it via mail to ‘u dot stoermer at steinberg dot de’. Thanks

It might also be worth going into the HALion Sonic SE 3 interface and tweaking some of its options, e.g. enabling multi-core support and increasing the maximum polyphony setting. You can then save those settings as the default for HSSE3.

Thanks for the responses.

Under Edit > Device Setup, I have ‘Generic Low Latency ASIO Driver’ selected. Sample rate is 48 kHz. Audio buffer size under ‘Device Control Panel’ is set to 10 ms (i.e. ‘small’). I’m also sending over an email with the project file referenced in my previous post.

When I first installed Dorico and HALion Sonic SE a couple of months ago, I had some stuttering issues with the audio. After googling around I found a post where someone else had the same issue, and the fix was enabling multi-core support. I did that and it resolved the stuttering problem. My current settings in the HALion interface are ‘8-core’ under ‘Multi-core’ and 512 under ‘MaxVoices’ (i.e. polyphony). See the following screenshot:

What happens if you reset the sample rate to 44.1 rather than 48 for Dorico?

You might want to reduce the number of cores you have allocated to HSSE from 8 to a smaller number.

Thanks for the project file. When I also use it with the Generic Low Latency driver set to 10ms block size it plays just fine here with me, also after repeated playback.
Also, I have only 4 cores here at home and even if I set HALion to use all of them, it still plays fine all the time. So there must be something else particular to your machine in order that the stuttering happens.
Do you run other audio programs in parallel? Do you have other software installed that might interfere?
Furthermore, do you have any other sound card than the Sound Blaster, maybe the standard Realtek or Connexant sound-chips on the motherboard? What if you use use that instead? Oh, and have you tried a different driver? E.g. on you can get another generic ASIO driver that is also for free. Have you tried with that?

I’ve tried reducing the cores from 8 to 7 and from 7 to 6. I still get the same issue after a few minutes of messing around.

I have no other audio programs running in parallel, at least to the extent of my knowledge. I do have a Realtek sound chip on my motherboard (ASUS Maximus IX Hero), but if I remember correctly, I uninstalled everything related to it (including the drivers) shortly after I built the machine because it was causing performance issues. So, things I will try next:

1.) Set sample rate to 44.1 kHz
2.) Install a different ASIO driver for the Creative sound card.
3.) Reinstall the drivers for the Realtek sound chip on my motherboard and try that. I don’t regard this one as a permanent solution - I would rather not use the Realtek sound chip at all if I can avoid it.

I’ll let you know how it goes.

Sure, but just try it out. That helps finding out where the real problem might come from. Thanks for trying it out.

Alright - I went to set the sample rate to 44.1 kHz, but I discovered that for the ‘Generic Low Latency ASIO Driver’, 48 kHz is the only option. So, I installed ASIO4All as suggested above. After monkeying around with it for several minutes, I still was having trouble getting any sound out of my speakers with that driver. However, at that point I noticed that I had a third driver option called ‘Creative SBZ Series ASIO’ - I don’t know why I didn’t see it before. I selected that one, and I’ve been working in Dorico for over an hour now with out any of the note-shortening that I was observing before. I’m cautiously optimistic that that may have resolved the issue. Thanks to everyone that helped out by suggesting things to try.

On a slightly related note, I’m still having two other minor playback issues that I figured I’d bring up while we’re on a role:
1.) I’m getting some irregularly-timed static or ‘skipping’ when I play notes on my MIDI controller, but not when I playback notes that have already been entered in Dorico. This was also happening with the generic driver that I was using before, so I’m not sure it’s related to the note-shortening issue.

2.) The ‘Sustain Ah’ instrument in HALion Sonic SE is horrendously flat, but only under most circumstances. For example, in the project file that I emailed, I have an acapella choir singing the first verse, then a piano comes in on top of them for one measure before the choir cuts out. If I play the piece back from the beginning, the piano and the choir are really out of tune when the piano comes in. However, if I start playback from the note where the piano comes in, the choir chord sounds like it’s perfectly in tune with the piano. As with the skipping, this was also happening with the generic ASIO driver.

These both fall in the camp of minor inconveniences that I could live with if I had to, but I’m interested to hear if anyone has any suggestions.

Do you find that the ‘Sustain Ah’ sound is flat in every project, or just in one? We replaced the flat and slow-to-speak HSSE choir sounds with the much-improved Soundiron Olympus Choir Micro sounds in Dorico 3, which is what you’re apparently using, but the problem you describe sounds more like how the former vocal sounds were behaving.

The skipping/static could mean your audio buffer is set too low (small).

Good call on the audio buffer size - after switching to the ‘Creative SBZ Series ASIO’ driver, I apparently had the buffer size set really small (2ms). Bumping it to 6ms fixed the static issue.

As for the flat ‘Sustain Ah’ sound, I checked it in two other projects, and it’s flat in both.

Sometimes this has to do with the difference between 48kHz and 44.1 kHz, but this would normally make all the notes out of tune rather than just one instrument.