Dorico hangs early during startup (no visual yet)


I’ve been using the free Dorico trial for a few days now, and up until now it worked fine. But since today, nothing visible happens when I start the software: no “active” marking underneath the icon in the Win10 task bar, no splash screen, no sign of any part of Dorico running except the “Dorico” background process listed in the Windows task manager window.

I already tried several suggestions I could find on the forums, all with no effect:

  • deleting the AppData/Roaming/Steinberg/Dorico folder
  • running cleanup_prefs_and_engine.bat
  • running the registry file to enable crash dumps - sadly, no crash dumps are generated, as apparently the program does not crash, but just stop any activity and hang for eternity
  • switching the active audio device

The application.log only ever shows two lines:

2016-12-13 02:12:45.456 : Dorico  1.0.10 build 4054 (Nov 23 2016)
2016-12-13 02:12:45.456 : Initializing Printer Services

Some system specs:

  • Dell XPS15 notebook, running Windows 10 Home
  • Audio devices: on-board audio chip, external USB2 Focusrite Scarlet 2i2

Attached are the contents of the Dorico AppData folder.
A memory dump of the “running” Dorico created via Windows task manager can be found here: Memory Dump
I’m happy to provide additional files if needed.

Thanks in advance!
CA (3.47 KB)

Thanks for sending the dump file - that’s very useful.

I can see that Dorico is hanging when it’s asking the OS to list all the attached printers, ie we ask the system to do it and it never returns. This suggests a problem with one of your printer drivers.

A few things to try:

  • reboot
  • After launching Dorico, alt-tab a few times to ensure that there are no printer message boxes open
  • Disconnect/reboot your printers
  • Check for printer driver updates, or reinstall them
  • plugin into a different USB port.

Thanks for the quick reply!

I did indeed try to install a new network printer prior to starting Dorico yesterday, but the printer autodetect did not succeed. I do not have any printers connected via USB, so I guess there will be something left in limbo with the network printer settings. I will try to clean them up and see if that resolves the issue - thanks for pointing me in the right direction!
(I suppose the last line in the application.log should have been a strong indication for me, but somehow I was preoccupied with thinking about audio device settings, having set Dorico playback to the Focusrite and then using my notebook on the go without the audio interface attached…)

Ah, if you have been trying to add a network device, then it’s quite possible that the hang is due to it searching for the device (unsuccessfully) on the network. Worth removing that device and trying again.

Final update: Removing the unavailable printer from the system settings did indeed do the trick. Many thanks for taking your time!

Excellent, great to hear.


Sorry to dig an old thread, but I had the same problem suddenly happening. It took me 3 hours to finally nail the problem to the printers, meanwhile, I tried:

  • Rebooting
  • Reinstalling Dorico
  • Uninstalling then Reinstalling
  • Deleting appdata folders the reinstalling
  • Running the cleaner script then reinstalling

Without any success - Dorico would appear in the task manager, but not run. Finally, after letting it go, I understood it was looking for network printers, and it managed to start after 25 minutes (!). I have attached the log where you see the printer log entries at the start: (9.06 KB)
The big problem here is that the 3 network printers here are my University printers - they have been installed on my machine alongside dorico since February when I got my new laptop. I have used Dorico intensively all last week without any issues whatsoever, and suddenly it started showing this behaviour tonight. No reason at all - I haven’t changed or updated anything at all with the printers, messed with their settings, nothing. Also, removing the printers is obviously not an option. If I open something else, like Microsoft Word, printers show up as being “Ready”, and are reachable (I’m at home currently, but I can send something to print at Work and it will work). Why does Dorico block on it?

I am using Windows 10, all latest updates.

Any suggestions? I have already lost a lot of time + all preferences in the resets, which is kind of annoying (and as you see from the logs, it’s past 3am in the night - I needed to prepare an exercise for my class tomorrow morning…)

PS: I tried closing and reopening it, in case it fixed itself, but no, still takes around half an hour to launch.

I’m very sorry to hear about the problems you’re having - I can imagine how frustrating it is if you’re on a deadline. I’ve tried to reproduce the problem here by creating printers that don’t exist, and by turning printers off, but I can’t get it to go wrong. This does suggest to me that it could be a driver issue, especially if you are up to date with Windows and it’s only recently started happening. So the first thing I would try is to update or reinstall the drivers for the printers in question. Also reboot if you haven’t already. You could also type ‘Update History’ into the Start box to show the recent updates that have been installed, and take a screenshot of that, as that might list some specific Knowledge Base (KBxxxxxx) issues that were addressed.

The reason for this happening is that Dorico asks the Qt framework to enumerate the printers, and for some reason this call doesn’t respond for 5-10 minutes for each of the offline printers. And there’s no way of Dorico knowing that the printer is offline until that function returns. There’s also no way of Dorico continuing until it does return. I don’t know why the system calls that Qt is making causes it to hang whereas the ones called by Word etc don’t.


I’ve done some tests since and I think I identified some elements. This problem of Dorico hanging with printers at startup happens only late at night, never during the day. So I guess that it’s not a problem of drivers, but that the printers go in “sleeping mode” and are somehow very slow to respond.

I compared behaviour in Sibelius, and while Sibelius starts right away, it hangs similarly for 5-10 minutes when I select the printer from the printer options. So it seems to make the call only to the printer when actually you start printing, vs Dorico calling all printers at startup. That might be something worth looking into for optimization purposes, as querying all printers probably slows down startup for some devices you might very well never use in your work session (I spend much more time composing/editing, and only printing at the end when it’s ready).

So Sibelius was hangning like Dorico, but Word starts and shows the printer instantly, no matter what. (Strange).

I understand that the call is going outside Dorico, and I’m not that familiar with Qt, but I wonder if it would be possible to implement a timer on a second thread while the printers are queried, and if the printer does not respond in a timely fashion at startup, show a pop-up “Printer X takes too long to respond, do you wish to ignore it?”, so that the user can choose to wait, or skip the printer, in which case it just wouldn’t show in the available printers for this session. That could be a catch-all for similar problems on various systems/configurations.

This definitely sounds like a bug in the driver, so I would suggest contacting the manufacturer, as the call should not be taking that long. There’s only so much that Dorico can do to work around bugs in third party products, and that time would take away from feature development.

At the moment it would be difficult to change how this works in Dorico; for one thing, it’s the call to list all the printers that is hanging, so Dorico can’t do anything to filter out ones that are taking a long time to respond. It’s likely that Word doesn’t query printers until you invoke print or print preview, but Dorico I think takes the opportunity to query the printers at an earlier stage.

Ok, I’ll try to contact the manufacturer of the driver. Thanks for the quick response.

Hi I know this is an old thread but I’ve been having a very similar problem. I’ve tried reinstalling Dorico a few times, running maintenance on the E-Licenser, restarted my computer, and still Dorico appears only as a background process in my Task Manager

This is the app log:
2020-03-03 13:01:17.589 : Dorico 2.2.20 build 1286 (Apr 18 2019)
2020-03-03 13:01:17.591 : Initializing Printer Services
2020-03-03 13:01:19.008 : Got information for printer: Send To OneNote 2016
2020-03-03 13:01:19.147 : Got information for printer: OneNote
2020-03-03 13:01:19.416 : Got information for printer: Microsoft XPS Document Writer
2020-03-03 13:01:19.745 : Got information for printer: Microsoft Print to PDF
2020-03-03 13:01:20.144 : Got information for printer: HP121D9C (HP Photosmart 7520 series)
2020-03-03 13:01:20.302 : Got information for printer: HP Photosmart 7520 series
2020-03-03 13:01:20.465 : Got information for printer: HP ePrint + JetAdvantage
2020-03-03 13:01:20.835 : Got information for printer: Fax - HP Photosmart 7520 series
2020-03-03 13:01:21.064 : Got information for printer: Fax
2020-03-03 13:01:21.119 : Initializing Core Services
2020-03-03 13:01:21.131 : Initializing Cached File Provider
2020-03-03 13:01:41.275 : Waiting for lock on cache summary file

It stays on “Waiting for lock on cache summary file” I have no clue what this means or what to do. Any help would be greatly appreciated. Thanks!

I would suggest following Paul’s advice to go to %TEMP% in Windows Explorer and delete the “Dorico 3” folder from there, then try running Dorico again.

That did the trick! Thank you so much. I really appreciate it! :slight_smile:

Just wanted to second that deleting the %TEMP% folder works for me when Dorico decides not to start (this has been happening quite regualary).

In Windows 10, the folder is located in C:\Users[username]\AppData\Local\Temp, or just hit the Windows key and type %TEMP%.