Dorico hangs with changed audio output

I’m running Mac OS Catalina 10.15 and Dorico 3.0.10.
All was working fine, including a much quicker startup of the app.
Now, suddenly, I can no longer get playback through the sound output socket from the computer.
I can get sound out if both the System preferences and Dorico Device is set to Built-in output.
Builtin audio.png
But now, if I change both System preferences and Dorico device to the stereo output (I have been successfully using an iMic USB Audio system for Dorico including version 3.0.10) the first thing I noticed was that the sample rate was blank and unalterable.
It has got worse since - now if I change away from Built-in audio, Dorico hangs.
iMic audio.png
I attach a Dorico Diagnostic file.
I also downloaded the Mac script to reset the audio engine back to its default state - but can’t figure out how to use it.

I forgot the diagnostic file!
Dorico Diagnostics.zip (451 KB)

I have a feeling that the problems you’re experiencing here are all due to the audio engine crashing on your computer, which will result in Dorico hanging, because it’s waiting for an answer from the engine that will never come. We’re looking into this.

Thanks Daniel. Good to know.
By the way, just today, Dorico is playing through the built-in output OK - not sure why it’s better again though it is a new project.
Also, when I try to go to a different output, it didn’t hang but I got this with an unchangeable blank sample rate…
Screenshot 2019-10-18 at 10.16.59.png
It may be helpful?

I had an almost identical problem with my USB headset. Worked fine with Dorico 2, upgraded to 3 seamlessly, then lost contact with my headset as soon as I upgraded to 3.0.10. iMac OS 10.14.6 Mojave. I had to swap backwards and forwards between Built-in audio and my USB Headset a few times and eventually Dorico picked it up. I seem to have solved it now though. Try this: open Audio MIDI Setup, go to Audio Devices from the Window menu, select your USB setup, and change the output to 44.1kHz. Restart Dorico. That worked for me; no idea why though…