Dorico has gotten very slow on large file

I have a large file (basically symphony orchestra, 23 minute long, single flow piece of music.)

there is a layout for the full orchestra with soloist,
one with full orchestra, soloist, and a piano staff (to create the piano reduction)
one with just the piano accompaniment plus the soloist,
two separate solo staves (one that allows ossia staves to show, the other which hides them)
and then each instrument in the orchestra’s individual part.

doing anything in the condensed score causes very long delays. I’m expecting this because of the condensing, but was wondering if removing the full orchestra+piano layout might help alleviate the speed issues a bit?

what causes larger files to slow down (other than condensing)?
I’m using NotePerformer for playback, have almost no work done in the “play” tab, everything is done from the write window (either in Page view, or galley view).
I have a windows machine, relatively fast (i7, lots of RAM).

any ideas? I can live with it, since I’m basically finished working on this piece. But I have a far larger piece in the pipeline and was hoping to maybe avoid the speed issue in future.

1 Like

Do you have only one of these layouts displayed or multiple?

Deleting a layout shouldn’t have much of an effect (if any) on the speed.

well, one at a time.
I haven’t used the split window option.
so I’m either working from the full score, or the piano reduction, or on an individual part (page turns, cues, etc…)

Yes, that’s what I would do too. I’d say it’s just the size of the file etc

Are there specific type of operations that are really slow?

today I had to move a condensing signpost and it was a good minute waiting for it to move back one measure.
I also did notice that the file itself takes much MUCH longer than most of my other Dorico files just to open from the launcher.

If you go to Project Info and scroll down the bottom, sometimes turning off the preview when saving can help a little (even when not actually using the “save” operation)

Are all your projects this size?

well, thus far in Dorico I have mostly chamber works, this concerto is the 2nd large-ish work I’ve done in Dorico, the other being a concerto for violin but with only string accompaniment.

However, I have 4 symphonies to transfer into Dorico at some point, two of which are fairly substantial orchestras and each a half hour long.

Otherwise, I have some chamber music and choral music to import into Dorico (I don’t like using XML, I prefer to start from scratch, which avoids translation issues)

I’ve noticed in large files with lots of flows - one today with 76 flows, about 80 measures max per flow - that during note input it would become sluggish. I narrowed that down to the auto-save function. (My HD are SSD drives). I would also recommend turning off any flows you aren’t working on at any particular time.

One other suggestion: navigate to the layout you were going to be working on, save, and close. When you reopen, don’t switch to a different layout. Dorico makes calculations on all layouts that have been opened during that session, so having only one open should help somewhat.


I had no idea!

It’s a bit of a simplification to say that Dorico performs calculations on all layouts that have been open during a session, but it is true that one way that often works to speed things up a bit is to close all windows and tabs apart from the one you want to work on, then close and reopen the project, which will make sure that Dorico is only performing calculations for that one layout.

Also, if you have condensing enabled, even if you’re working in galley view it’s worth unchecking Edit > Condensing, as there is some penalty for edits when condensing is enabled, even if the view you’re currently looking at can’t show condensing.