Dorico imports the wrong rhythm from midi

I exported a midi from my DAW (Studio One) and when importing it, it gives me a bunch of 8th notes instead of the 1 8th note 2 16th note rhythm I wrote. Yes, the midi is quantized.
Any ideas on why this is happening and how to fix?

Clearly your quantisation options were set incorrectly.
Select all then Edit>Requantize…. should fix it.