Dorico in tablet mode

I have Asus two in one laptop. In tablet mode Dorico’s transport buttons doesn’t react at all. Is this problem of laptop, or there’s something wrong with the doriico?

Okay, I’ll say it now:

No, it’s not you, there’s clearly something wrong with Dorico and touch input on Windows.
It’s mostly broken and in its current state unusable. Case in point: I can’t even use the mode switches by tapping them…
I’ve been waiting for the team to fix this for years now.
Sorry to disappoint you.


1 Like

Since our office move we don’t have easy access to any touch-enabled Windows devices so it’s difficult for us to test this, but I will see if I can lay hands on our Surface device, wherever it may be, and try to look into what is happening here. It won’t be imminently as I am not going to be in the vicinity of our office for at least a week.


I bought this laptop mainly for Dorico to be used in Tablet mode. So sad that the problem is not fixed yet.

I have a Dell Inspiron 2in1 and I just tested using the Transport Buttons with the Dell Pen as well as with a finger Touch. Both work immediately on this touch screen.

Curious. I have the same computer. Will investigate further…

I have an HP Spectre and I decided to try it in tablet mode just now.

I cannot control any of the hub elements (although finger taps are being registered which is shown by a little animation… just nothing happens)

As for the main window, everything seems to register except the top main banner, so I cannot switch modes, or engage transport controls, or change the layout. But the side panels and the properties are all responsive.

What OS Version do you have? Have you tried to enable the Pen in the Windows settings?

Even if you do not have a pen, this might enable some more functions in Windows. For whatever reason I can use finger touch and the Dell pen for Dorico and it reacts immedately and correct.

As for pen, I’m trying to test it but the pen is dead and I think it might have gone bad… I’ll have to report back later.

I’ve tried both, with finger and with pen, but most of the functions are nonresponsive. It seems like Dorico itself is not adapted for usage in tablet format.

The same happens here!

I think it’s less a “tablet issue” and mostly a touch issue de facto. The UI seems oblivious to touch. It doesn’t react to touch events, which are not the same as mouse events (OnClick, etc.) in Windows.

Amazing they never bothered to test on a single touch-enabled Windows device, though.

Maybe it has something to do with Qt and how the toolbars are built?

Seems a reasonable guess.

Perhaps there’s different underlying code for the header that wasn’t revised when the program was migrated to the newer Qt code base. The side panels have been updated since 1.0 because there have been additional functions tucked in here or there (lines, for I stance) whereas the fundamental mode buttons haven’t really changed, so perhaps their code was left as is.

I’ll stop playing court jester now and sounding the fool.

Amazing indeed…