Dorico increases OS volume on launch

I’ve run into a pretty gnarly bug with Dorico changing the system volume on launch on macOS. This has really bitten me when I’ve launched Dorico, then gone to another app to play audio, only to get my ears blown out. :grimacing:

Steps to Reproduce

I’ve been able to repro this issue 100% of the time with these steps:

  1. Set system volume to somewhere around 25% (the actual setting doesn’t really matter, this is just to highlight the big jump in volume)
  2. Launch Dorico
  3. Check the system volume again

Expected

The system volume is unchanged.

Actual

The system volume has increased to 100%.

System Info

  • Dorico Pro 3.5.12.1066
  • macOS 10.15.7
  • Audio Device → ASIO Driver: Built-in Audio, aka MacBook Pro Speakers in the macOS system preferences

Let me know if there’s any more info I could provide that’d be helpful for debugging!

Try this:
Open preferences → Play → Audio Device Setup… → Device Control Panel…
and here uncheck the “Set Device Attenuation To 0 dB”

Yes, I’m afraid this isn’t a bug, but rather a deliberate choice on the part of the team who build the CoreAudio2ASIO component that Dorico (and our other applications, including Cubase), on the grounds that if you are using a pro audio application like Dorico (or Cubase), you would have an external mixing device, external speakers, etc., and would want a consistent level output from your application so you can control the output level on your outboard equipment. Unfortunately this isn’t true for everybody, of course, and at the moment there’s no way for us to change this default.

The good news, however, is that the team who maintain this component recently had a change of heart on this issue, and in future versions of Dorico we expect to be able to include a revised version of the CoreAudio2ASIO component that does not set your volume to its maximum level by default.