Dorico is faster than I want!

When playing back a piece the playhead doesn’t follow the tempo, it’s far ahead (about 1-2 measures).
That means the playhead reaches the final bar (end of piece) earlier than the playback does.
The result is that I never ever can hear the last bars of my piece.
I wish Dorico would be a bit more patient and follow my music :wink:
I have the latest version installed.
Any thoughts?

(Mac Pro 2013, Focusrite Saffire pro 24 firewire).

Are you able to attach the score here (or a cut down version of it that shows the problem)?

Sure, here is one example
but actually it affects all my Dorico files.

Any ideas?

I’ve tried playing this and it’s fine on my system. Are you using a sample rate other than 44.1kHz? We have seen some similar types of problems at other sample rates, so I wonder if it could be that.

Yes, at 44.1 it plays to the end but the playhead disappeared, even after rebooting.
That means I have to switch from 48 to 44 each time I use Dorico, and have to quit Logic X because when it is open it forces my audio interface back to 48 (my Logic is set to 48 by default because I do TV and film music.)
I am doing everything in 48kHz.
Dorico seems to be the only music app on my machine that doesn’t like 48kHz.
A bug or standard?

FWIW Dorico works fine for me at 48 on Windows (using ASIO4ALL, not the Steinberg ASIO driver) - so maybe it’s a Mac issue. (I use 48 because 48 and 96 are the “native” speeds of my audio interface - 44.1 brings in more layers of frequency conversion)

It’s not that Dorico shouldn’t work at other sample rates, just that that may be significant in working out how to reproduce this bug. If the playback line is consistently about 8% ahead of where it should be then that may explain what’s going on. There were some early bugs we had that were related to the internal state not using the correct sample rate when the output device is mapped on project loading, and so it’s possible that this is a regression.

Also, the playhead will disappear when playback stops, unless you have the preference set to keep it visible.

What buffer latency do you have set for your audio driver?

Also with my MacMini and Built-in Audio set to 48kHz the playhead in Dorico is in sync with the audible result.
What if you restart your machine and just run Dorico, no Logic or other audio app, same issue at 48kHz?

Interestingly, one of our beta testers just reported a similar problem. Same thing, he has to work with 48kHz and also had the playhead running ahead the actual playback.

He went to Edit > Device Setup, actually the driver was set to 48kHz, and then switched to 44.1kHz. Closed the dialog, went back and changed back to 48kHz and then everything was fine again.
So something in the internal state must have been out of sync.

Does maybe this recipe also help you?

My playhead has disappeared completely (some days now), so I can’t tell if it is in sync or not because it is invisible.

Hm, that’s odd. Well, this now is something where we need some advice from the London team.
If I were you, I’d delete all the Dorico preferences and see if this might rectify things, but just guessing…

It’s it appearing in Play Mode?

After running the latest update all is fine now…

Thanks for the update. Then let’s hope it stays like this, but please shout out if it happens again.

I have the same issue and I have updated to the latest version and it has not been resolved yet. The playhead moves faster so after a couple of measure it is noticeably ahead of what is being played and heard. Also, I can never hear the end of my piece either as the playback stops once the playhead reaches the end of music.

In my device setup, there is no option of 44.1KHZ. The only option is 48KHZ so I can’t tell if this is what’s causing the problem.

This is something that should be improved in the next update.

Is the update going to be released this month?

yes june 2017