Dorico keeps automatically changing my notes

Whenever I enter a note in Write Mode, the program will automatically change my note values. So if I enter a whole note, the program will automatically change the whole note to a half note tied to a dotted quarter note. Does anyone know how I can disable this behaviour so that I can enter any note I want without having the program automatically changing my note values? Help!!!

This looks like a bug… and the kind I do not remember having read about in this forum. Have you tried to restart Dorico to make sure this goes on ? If so, send here a little dorico project (that you will zip in order to send it) that displays that behavior, for Dorico’s team to have a look at it.

How do I post the file to this thread and can I send a video of the problem, too?

It doesn’t sound like a bug to me: it sounds like your expectation of how the prevailing meter should be subdivided rhythmically and Dorico’s are at odds with one another. When you input notes in Dorico, you’re inputting notes that are of the specified length, but they are not guaranteed to be notated using a single notehead. For example, if you input a note of a quarter (crotchet) in duration but do so on the third 8th (quaver) of 6/8, it will be notated as two eighths tied together, because it crosses the compound beat boundary.

You can force Dorico to use only the notations you specify by switching on Force Durations (key command O) but I would advise against it. It would be better to figure out how to work with Dorico’s features for setting out the music clearly according to the meter. Can you tell us what meter you are trying to write in?

Here is the file.
note changing problem.zip (645 KB)

I’m using 4/4 meter in the file above.

I am trying to enter whole notes in 4/4 meter using the violin. What I notice is that when I enter small notes like eighth notes, everything works. But when I try to enter whole notes, the notes are changed. What exactly should I be doing?

Dear jamozart1,

When I answered your first post, I understood the value you entered was changed — if I count properly, there is one 8th missing in your whole note description. This is where the bug lies ^^
Now that I see your file, I see that Daniel has forseen your problem, even if you did not describe it in an accurate manner.
Dorico is doing its job fine, and if you need it to display another kind of rhythmic association, do as Daniel suggests. :wink:

Are you using mouse input, jamozart1? If so, try to make sure that you are clicking close to the start of the bar. It looks like you must be missing and clicking too far to the right.

Take a look at the videos introducing note input on the YouTube channel – I think a few minutes spent there could save you a lot of time overall: Write mode in Dorico.

I have this problem too. I will work through it until I find out what the problem is with the way I am trying to work. This is more or less the first time I have used Dorico, and my instinct is to jump in, and only to read the manual if I have to. However, a quick google search will reveal that this is a widespread problem, so it would suggest to me, that either there is something unintuitive about the process, or that the way to write in Dorico is not well explained for the absolute beginner by the manual and videos.

Please do not tell me that I have not described the problem accurately - that would simply be rude, even in French.

Many thanks

You have described this problem perfectly: you jumped into a very sophisticated program without consulting the manual. Maybe the problem is with someone’s intuition rather than with the software.

Virtually every time I have experienced this it winds up being one of the two scenarios described by Daniel in this thread.

  • Alt-click copying notes and am positioning the mouse pointer too far to the right.
  • I’m at odds with Dorico’s decision in respect to readability.

Two similar situations in which I was frequently befuddled when I first started using Dorico:

  • trying to enter rests of a specified length. The quick and surprisingly easy solution is to enter your note where you want it, or if already entered, use alt-arrow to move it to the proper rhythmic position and let Dorico sort out the rests.
  • Inadvertently putting Dorico in “insert” mode (I), resulting in all sorts of unexpected behavior, because I don’t realize it is in insert mode.

There will always be a handful of situations with new-to-you software when the behavior seems counter-intuitive. Hang in there with Dorico, after a couple of weeks, you will be loving life.

perhaps it might be a good idea to start looking at the various Note Grouping options (in Notation options). There are a wide range of different choices as to how you split or do not split notes. It’s not a bug any more than it was in 2017 as far as I’m aware.

I would really love to have the following option in the Notation Options:


Or is it a plain notational mistake?

This is where Force Duration (the “O” key) is necessary.
As others have asked, I wish there was a option for this to be turned on all the time.

In 35 years I’ve never seen a less intuitive program. And I had Coda Finale 1.0 for Chrissakes. I was successfully notating my first full-orchestral score in Sibelius the first day I bought it. And here, 30 minutes in I literally still can’t just play a note, hit the value and move on; it’s just… everything is a fight and frustrating. What a miserable, unnecessarily joyless, a-musical experience this is.

“Relearn the way you think about inputting music to accommodate Dorico.”

No thanks. Why don’t you put in an option for people who know what they’re doing and how best to notate their own music. You could call it “Musician Mode.”

My kingdom for Sibelius 6.

BTW this is my official review, feel free to post it.

_Mike Verta

Dorico is a better musician that you give it credit for: but you have to tell it what you want. There are detailed settings in Notation Options for you to instruct Dorico exactly how your music should appear. Then you won’t be fighting Dorico, because you will both be in agreement. And when you do want to do something inconsistent, you can use Force Duration (O).

Personally, I find using Dorico much more joyful than Finale ever was. But if you really want a program that does nothing for you, and requires you to do it all yourself, manually, repetitively, then you have that option.

Sorry to hear you’ve been having problems as you get started with Dorico, Mike. I think in particular if you’ve been using another program for many years, it can be a struggle to relearn things that feel like second nature from your previous program. Are you trying to use MIDI step-time input? Is the problem you’re having that your MIDI keyboard isn’t detected, or is it that you can’t figure out the note input method? Step-time input in Dorico is very similar to that in Sibelius: really the only difference is that the number keys for the durations are different. If you let us know what in particular you’re having problems with, I’ll be very happy to try to help you further.