Dorico not re-beaming when shifting or copy/pasting notes

When I’m using alt+arrow keys to shift notes around or copy-pasting Dorico does not re-beam the notes according to their new location, but keeps the beaming “intact” across barlines etc. I can’t seem to recall this being the normal behaviour for Dorico in the past.

Is there an option for avoiding these “sticky” beams? Or any quick fixes to automatically re-beam an entire selection, without manually selecting each beam group?

I find it very useful to be able to shift phrases around when composing/arranging, or as in this case when I’m editing scale exercises to fit a certain range.

dorico beaming

beaming-example.dorico (370.7 KB)

I captured the GIF with Dorico 3.5.10 but I tried upgrading to 3.5.12 and the behaviour remains the same…

Select the passage and go Edit > Beaming > Reset Beaming.
Did this perhaps start as MusicXML? If so, is Preferences > MusicXML Import > Notes and Chords > Beam Grouping ticked? If so, you may want to untick it for next time.

1 Like

You are bang on! Something felt a bit off. I’ve unticked it now, and will keep an eye on those settings next time I import MusicXML. Thanks a bunch!