Dorico Pro 3.1 Hangs When Printing with Foxit PhantomPDF Printer

Hello Dorico team,
Dorico Pro 3.1 hangs every time when I’m trying to print pdf file via Foxit PhantomPDF Printer.
There is no crash dumps when performing diagnostics. The only way to continue using Dorico is to
click the enclosed in red option in the (Not Responding) dialog (check the screenshot):
Dorico Pro 3.1 - Hangs When Printing with Foxit PhantomPDF.png
I hope this could be fixed! :slight_smile: Foxit is one of the best rated PDF printers on the market.

Thank you in advance! :slight_smile:

Best regards,
Thurisaz

Dorico has a perfectly good Graphics Export function. Do you have a particular reason for not using it?

Hello Leo,
Thank you for the reply! Well, I would like to be able to export PDFs with my favorite printer, too. :slight_smile:
There is no such problem with the native Windows 10 Pro PDF printer. But Foxit has better output. :slight_smile:

Best regards,
Thurisaz

P.S: By the way I’ve sent you a friend request on facebook few days ago.

The Windows 10 Pro PDF printer is neither here nor there; I’m talking about the Graphics Export function in the right panel of Print mode. What doesn’t it do that you need?

I know that Dorico can export nice graphics, but mostly I prefer to directly export PDF, even with higher dpi resolution than the available
in Dorico. Currently the app allows me to export graphics maximum to 1200 dpi, Foxit Printer - up to 2400dpi.
And saves me time that I have to spend combining the graphics into PDF file… :slight_smile:

Except that actually, anything that can’t be vectorised is exported at 2400dpi by Dorico’s own graphics export. See https://www.steinberg.net/forums/viewtopic.php?f=246&t=154427&p=829664&hilit=pdf#p829664

Thank you for the link, Leo! :slight_smile:
Still Dorico shouldn’t hang even if external pdf printer is used. :slight_smile:

Best regards,

Is it possible that a Foxit dialog is appearing behind Dorico, and that Dorico can’t do anything until you’ve dealt with the Foxit dialog? I’m just speculating, here - I’ve previously tried a few PDF printers (on Windows) and I’ve never had one cause Dorico to hang.

Nothing related to Foxit appears at all, not even behind Dorico. Only the window for saving location.
Actually this is a bit strange… The printer properties dialog should appear, too…

Dorico doesn’t currently provide any means to show a printer’s properties window on Windows (or indeed on Mac, though there is not really a direct analogue for the Windows printer properties dialog on Mac anyway), which is something we plan to do in future.

Daniel hello,
Thank you for the reply! :slight_smile:
Well, we are not talking about the Windows native PDF printer, but for FoxIt PhantomPDF Printer, which is third-party.
Please, check the first comment of mine, and the screenshot! :slight_smile: Dorico always hanging when FoxIt Printer is involved.

Best regards,
Thurisaz

Unfortunately, we can’t tell anything from a screenshot. You will need to create a minidump file when Dorico hangs. Next time this happens, please download Process Explorer from https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer and run it. In the list of processes find Dorico3.exe, rightclick on it and then choose Create Dump > Create Minidump. Then zip up and upload to a service such as DropBox, OneDrive, WeSendIt and paste the link here.

Paul hello,
Thank you for the assistance! :slight_smile:
Here is the link with the minidump file:
Dorico3 Minidump.zip (1.05 MB)
I hope you’ll find what may be the cause! :slight_smile:

Best regards,
Thurisaz

I can see that Dorico is hanging because the Foxit PDF driver (fpmvpr_drv) is requesting data from the network that doesn’t arrive. Anything relying on network data should have a timeout so that control returns to the calling application. So this looks like either an error in Foxit driver where it’s not timing out, or a firewall/AV issue where there is a system dialog requesting access. Or perhaps you have a network printer that isn’t connected or configured correctly. In any case, this is outside of Dorico’s control.

ntdll!NtWaitForSingleObject+0x14
mswsock!SockWaitForSingleObject+0x1bd
mswsock!WSPRecv+0x5d2
ws2_32!recv+0x170
fpmvpr_drv+0x81b18

Paul hello,
Thank you for the reply and help! :slight_smile: I will check what may causes this problem with the fpmvpr_drv. I haven’t set any restrictions to Foxit Printer Driver… I don’t have network printer, too

Thank you once again! :slight_smile:

Best regards,
Thurisaz

I am unable to reproduce the issue here with Dorico 3.1, Windows 8.1 and Foxit Reader 9.7 (not Foxit PhantomPDF).

Hello Boscoverdi,
Finally I was able to figure out how to fix this issue. Now it works fine! :slight_smile:
The PDF Printer was trying to launch FoxIt PhantomPDF to preview, but some configurations I made before prevented
from auto-launching of apps.

Best regards,
Thurisaz