Dorico Pro 3 Actual Page Size

Hello dear colleagues and Dorico crew,
I need some help here. I have found that, on my QHD 2560x1440 monitor, page zooming at 172% is equal to the Actual page size, no matter A4, A3…
Now I’m trying to create a macro script which will automatically jump from any zooming to 172%. Unfortunately without any success.
The macro recorder is able only to record the appearance of the Custom Zoom dialog and nothing more…

Would be nice if the team could add Actual Page size to the Zoom section (such function exists in FoxIt Phantom PDF), or at least some
help to create my own script will be appreciated.

Thank you in advance! :slight_smile:

Best wishes

If you’re willing and able to get your hands dirty with editing the key commands JSON file in a text editor outside of Dorico itself, you can give yourself one-key access to your preferred zoom level. What I suggest you do is assign a key command to the View > Zoom command in the Key Commands page of Preferences, then quit Dorico. Now open the file %LOCALAPPDATA%\Steinberg\Dorico 3\keycommands_en.json in your favourite text editor. Look for the line that looks something like this:

					{
						"View.Zoom?ZoomPercent=100" : [ "Meta+Z" ]
					},

and change the parameter value of ZoomPercent to 172 instead of 100. Save the JSON file and restart Dorico, and now when you hit that shortcut, Dorico will zoom to 172%.

Hello Daniel,
Thank you very much for the reply! :slight_smile: Unfortunately the steps provided by you don’t work…
BTW, the Dorico 3 folder is located in Users\UserName\AppData\Roaming\Steinberg

I did this:

"shortcuts" : [
					
					{
						"View.Zoom?ZoomPercent=172" : [ "Ctrl+H" ]
					},

After restarting Dorico and pressing the short cut, it always zoom to 100%.

Best regards,
Thurisaz :slight_smile:

  1. Are you sure it’s in the kGlobal section? (it certainly works here).
  2. The whole point of %APPDATA% is that it points to wherever your Roaming folder is. Yours might be Users\UserName\AppData\Roaming, but other people’s may be different.

The %appdata% Windows shortcut takes one to C:\Users_username_\AppData\Roaming.
%localappdata% does the same.

I’m sorry; I’d missed Thurisaz’s point, which was that Daniel mistakenly pointed him/her/them to %LOCALAPPDATA%\Steinberg\Dorico 3\keycommands_en.json rather than %APPDATA%\Steinberg\Dorico 3\keycommands_en.json. Ignore me.

As you well know, I have misread on occasion as well. I would never ignore you for fear of missing something valuable.

Hello guys,
Leo, I’m male and Thurisaz is the name of the God Thor’s rune (a letter of the Scandinavian alphabet - Elder Futhark).
The symbol is believed to hold the supreme creative power, but also the supreme power of destruction. :slight_smile:

On the topic! Yes I did the editing exactly in the file where Daniel have said. You can check the screenshot below.


Just it doesn’t work here… Windows 10 Pro 1909

Best regards,
Thurisaz

I can’t get it to work either. If I follow Daniel’s instructions, I get just “View.Zoom” not “View.Zoom?ZoomPercent=100” and pressing the shortcut gives a zoom of 100%.

If I manually add “?ZoomPercent=125”, the keycommand disappears from the UI and it doesn’t work at all.

OK, thanks, folks, I’ll check into this further and report back.

I’ve tested this again, and the following command certainly works:

					{
						"View.Zoom?ZoomPercent=172" : [ "§" ]
					}

Make sure you put this in the kGlobal context within the key commands file.

Good evening Daniel,
I hope you are doing well! :slight_smile:
Thank you for the reply! :slight_smile: The symbol you are using in this example “§” , can’t called a short cut since it’s combination of Alt+0167 (5 buttons).

Best regards,
Thurisaz

It’s very interesting that in the Key Command dialog for View > Zoom we have ‘ZoomPercent’ : parameter, we can write there, but finally it is not saved.

Yes, you need to do it by hand in the JSON file; it won’t work in the dialog itself.

You might not be able to describe this as a shortcut, but those of us with British (mac) keyboards can. It’s one button.

This does raise questions, though: what language are you running Dorico in, what language keyboard shortcuts are set within Dorico Preferences, and are you definitely editing the corresponding JSON file?

Hello Leo,
My Windows 10 Pro uses US English, but my keyboard is EditorsKeys - Steinberg Cubase (British English) and I’m running Dorico in English.
Here is the keyboard for Windows… there is no this symbol, it’s only available for Mac. https://www.editorskeys.com/collections/steinberg-cubase-keyboards/products/cubase-keyboard-backlit?variant=41540762570
I’m from the Balkans - Bulgaria.

Best wishes,
Thurisaz

This is quite the mystery, then. I’ve just opened up my Windows machine just to see if it’s a weird Mac/Windows discrepancy, and Daniel’s suggested JSON tweak works just fine on my WIndows machine. I don’t understand why it’s not working for you.

Ctrl+H isn’t defined as a default Dorico keyboard shortcut, but is there a chance you’ve already defined it as a custom shortcut for something else?

Something happened after I edited the JSON file again, but this time in Windows Notepad?! Now it works fine…
Another strange thing happened… Now Dorico doesn’t allow me to change the Key Command in the dialog. I can delete the previously assigned
but I can’t add new one… I even trashed the keycommands_en.json file, in order Dorico to create new one, but still I can’t add new command short cut to Zoom. The button Add Key Command stays always inactive…

Greetings :slight_smile:

I also tried again with Windows Notepad and this time it worked. I had used Notepad++ before.

You need something in the ZoomPercent field or the Add button doesn’t activate even though that field seems to do nothing.

Craig F,
Even if the ZoomPercent field is populated it doesn’t make the Add button active. It is always inactive.
Before I was able to add Key Command without filling the ZoomPercent field.
Notepad++ was very good editor…

Greetings :slight_smile: