Dorico Pro 4.0 and NotePerformer 3.3.2

Hello,

I am on Windows 10 and just upgraded to Dorico 4.0, and I cannot get NotePerformer to play. I tried it again in Dorico 3.5.1.32 and it worked grand.

I’m not sure if this is a Audio Engine issue or a VST issue. NotePerformer64 is listed in the VST Rack, but I cannot get the NotePerformer mixed to show up when I try to launch it.

I’ve tried resetting the cache, the audio engine, changing ASIO drivers, changing bitrates, running VSTAudioEngine5.exe separately, making sure NotePerformer is whitelisted and not blacklisted and deleting VSTAudioEngine5_64 and Dorico 4 AudioEngine_64 from my Roaming directory.

I don’t believe VSTAudioEngine5.exe is seeing NotePerformer, as when I run it, NotePerformer does not flash by as it is loading.

Also, every time I run VSTAudioEngine5.exe then try to run Dorico Pro 4.0, it hangs on “Audio engine: Waiting for connection” and won’t progress, requiring me to cancel the process and restart Dorico.

Dorico Diagnostics.zip (399.3 KB)

Any help would be much appreciated!

Welcome to the forum Adam.
It’s a little weird and I:m not quite sure, but it could be because Dorico’s audio engine “sees” NotePerformer double, namely first in C:\Program Files\Steinberg\Vstplugins\NotePerformer64.dll and the second in C:\Program Files\Common Files\VST2\NotePerformer64.dll.
Try to take out one of the paths from the VST2 Search Path list in the Dorico Preferences dialog. Then restart Dorico and try again. If it still fails to load, please make a new diagnostics report. Thanks

No Joy. Every time I close Dorico Pro 4.0 and re-open it, it rebuilds the default VST Plug-in Paths, so I delete NotePerformer64.dll from C:\Program Files\Common Files\VST2\NotePerformer64.dll and it still did not fix it.

Attached are the diagnostics.
Dorico Diagnostics2.zip (439.0 KB)

I’m noticing in VSTAudioEngine.1.log,
-line 242-243: NotePerformer64 Not Loaded!
-line 373: exportPluginState plug NotePerformer64 not OK!

Any ideas why Dorico would be not loading NotePerformer64 after accepting the plugin from the whitelist?

Weird, really weird…
Then please do the following:

  • Stop Dorico
  • Go to C:/Users/raven/AppData/Roaming/Steinberg/Dorico 4 AudioEngine_64
  • Delete the files
    Vst2xPlugin Blacklist Dorico 4 AudioEngine.xml
    Vst2xPlugin Whitelist Dorico 4 AudioEngine.xml
    Vst2xPlugin Infos Dorico 4 AudioEngine.xml
    VstPlugInfoV4.xml
    VstPresetCompatibilityPlugInfo.xml
    VstPresetVersionPlugInfo.xml
  • Start Dorico
    (All except one of those files will get recreated and filled automatically)
  • Try to load NotePerformer. If still no success, please create yet another diagnostics report.
    Thanks

No joy :frowning: Should I try deleting these files from /VSTAudioEngine5_64 as well?

attached is the diag report
Dorico Diagnostics3.zip (442.0 KB)

No, that other folder is only relevant if you start the audio engine by itself, something that users normally should not do. It doesn’t do harm, but also does not do anything good :wink:
But please try again with a new project from scratch and apply the NotePerformer playback template. Does that do then?

Deleted the files again, opened a new project, input a few notes, loaded the template, and still no joy… this is very strange.
Dorico Diagnostics4.zip (440.0 KB)

SOLVED! Ulf and I believe that the folder Dorico is installed in must be called Dorico 4, otherwise it breaks!

When I installed Dorico, I installed it directly to a directory I called X:\Steinberg where I had another folder X:\Steinberg\Dorico 3.5 from my previous Dorico installation . After pulling \Dorico 3.5 out from that folder, copying X:\Steinberg and renaming it Dorico 4 , the dependencies were met and NotePerformer started as expected!

EDIT: Interestingly, I cannot delete X:\Steinberg as ...\fonts\DoricoIcons-Regular.ttf and ...\fonts\SourceSansPro-Semibold are being called by Windows on startup. I deleted the rest of the contents of the folder and Dorcio 4 still runs as expected from X:\Dorico 4