Dorico SE 4.3.11 MIDI Import Options dialog missing

My guess would be that SE might be lacking a feature that full version has, but the manual says that it does. There are other confusing features that the online tutorial explains for Dorico SE that I could not find. Is there a problem with my installation?

Where are you looking, @dlbeaty – are you definitely referring to the Dorico SE 4 manual? As far as I can see, the Dorico SE 4 manual doesn’t refer to the MIDI Import Options dialog.

Edit: Ah there is a reference on the page about opening projects/files which shouldn’t be there; I’ll get that marked up.

1 Like

Thank you. I later did see the link you posted. Another problem I had was in the “Starting your first project with Dorico SE” video, at 8 minutes he tells about setting the split points in the preferences on the same page. There is no option in my version. See:

That playlist was made in a previous version of Dorico; split points are now handled differently, because Dorico handles voices on grand staff instruments in a more intelligent way (i.e. the split point can vary, depending on the voice leading).

1 Like

Hi Lillie_Harris,

Using Dorico SE, I’m trying to import a midi file recorded on my Clavinova. But there is no bass/treble split at all.

Even after I assign a “piano” instrument, no split occurs.

As my composition lasts 21 minutes, it’s just impossible to switch notes one by one.

I tried Sibelius and Musescore and both do the split.

As there is no options at all for MIDI import in Dorico SE, what can I do ?

Thank you

Welcome to the forum, @erwan75. Are you able to set your MIDI file such that it uses program number 0 on channel 1 (i.e. matching the General MIDI mapping)? That should be enough to help persuade Dorico that your MIDI file contains music for piano.

Thank you for your answer.
I tried to check the “program number” in the file using different midi file editors but I couldn’t get the exact information (i didn’t find any Windows software able to show me exactly what is inside my midi file).
All I can say is that they all display “acoustic grand piano” straight after opening the file, so I guess it is already set.

Great – so perhaps there is something else going on. Would you mind zipping up and attaching one of the MIDI files that’s giving you problems, so I can take a look at it?

Thank you for your help.

Here is a small midi file i recorded in the exact same context : (1.1 KB)

Hello dspreadbury,

Just to know if you’re still on my issue ?

Thank you

Yes, I am, but I can’t always look into every issue right away, especially when they’re involved. We ask that you don’t bump threads on the forum, though I know it’s frustrating to have to wait for an answer. Sorry for the delay. I will get a chance to look at this again later on today.

With apologies for the long delay in coming back to this, I’ve finally spent some more time looking at this today.

The problem is that the MIDI file provides zero clues to Dorico about the kind of instrument it should choose: there is no track name, there is no program change. In Dorico Pro it’s easy to tell Dorico at the time of import what instrument to use, but of course this option isn’t available in Dorico SE.

Unfortunately I can’t offer you a good solution at the present time. Much as it pains me to say it, you may be better off using one of your other applications for this project. You may find that having imported your MIDI file into one of those applications, exporting a MusicXML file from there that you then import into Dorico SE gives a good result. Sorry for the disappointment.

Thank you for your time & help.

If it could help anyone :

I found a solution with the very kind help of the developer of the iOS app called “MIDI RECORDER WITH E.PIANO” I’m using to record my impro’s with my iPhone.

The trick is to set the MIDI file type to 1 and add a “Piano” instrument field to the track.

This can easily be done using a MIDI file editor, for example Sekaiju, an open source application I strongly recommend to anyone trying to understand & fix MIDI stuff.

Now Dorico imports the file correctly.