Dorico SE4 - no sound

Hi. I’m using Dorico SE4 to decide whether to migrate from Sibelius. However, I have no sound at all. I have watched a Dorico specific video about solutions to sound problems but none of the issues apply. My audio interface, drivers and settings are all in order and work perfectly with GuitarPro7, Musescore, Sibelius and Cubase 12 etc. The videos I watch all assume there is midi being triggered with a mouse on the keyboard in Halion.
Everything was installed correctly including Halion. I can see all the libraries AND patch names but when I come to load a sound I get a red cross in the track. I have reinstalled the Halion library more than once. In Halion there is a keyboard at the bottom, when I click my mouse there is no midi activity or sound. I thought it was a Halion problem but I tried a 3rd party Vsti and that also has no midi or sound. It seems therefore like a Dorico issue. Does anyone have any thoughts and possible solutions. I am quite aware about drivers, sound settings etc. this feels like it’s something else. Cheers Jon.

What Operating System are you on?

Hi Juergen. I’m using Windows 11. Jon

Hi @JuergenP, please load a project that should have sound, wait until the Play button is turning green and then from the menu choose Help > Create Diagnostics Report and post the corresponding zip file here. Thanks

Hi Ulf,

I just asked for the OS :slight_smile: , the question came from @JonnoRAS

@JonnoRAS can you please have a look at @Ulf response?


Hi @JuergenP, sorry for my mistake and thank you for the correction.

Hi Ulf. Thanks for looking at this. Here is the ZIP file created from Dorico. Thanks Jon
Dorico (440.7 KB)

Thanks for the data @JonnoRAS .
Where do you expect Dorico to play out through, because currently it is set up to use the Generic Low Latency Driver and that one uses the U24XL SPDIF ports to stream audio to. Is that what you expect?
Did you actively set this setting via Edit > Device Setup?

Hi Ulf. I use an external USB Audio interface U24XL for all my audio - input AND output. I have set the driver to be the low latency driver as the U24XL doesn’t have a specific driver and it works with all my other software. This is the path I need the audio to be routed to. Cheers Jon

Thanks, I understand. So what if you open Dorico and start a new project from piano template. There should be a few empty bars. When you switch on the Metronome and press the Play button, can you hear the metronome click? Does the level flicker in the mixer window?

Hi Ulf. I’m away from my system for a few days now. I’ll check that out when I get back. I have tried to play the Coldplay song (clocks) that comes with Dorico SE4. Halion loads the correct patches from the library and they appear in the Halion track list and the Dorico play section. However, there’s no midi data or sound. I suspect it won’t work with the piano template that you suggest but I’ll give it a go. Thanks Jon.

Yes, please try it out. We need to more specifically find out where the problem is. In the audio processing, in the MIDI streaming, in…?

Hi Ulf. Sorry for the delay, I’ve been away a few days. Just tried what you suggested but there is still no midi or sound. I tried changing the preferences to auto load Halion and not autoload Halion. Made no difference - I used the solo piano template from the hub. Any thoughts. Jon

Ulf is now away on holiday himself, but could you please start a new project based on the Solo Piano template, add a few notes, then save and attach the project here?

Similarly, I’d be interested to know if you have any more success using the FlexASIO driver rather than the Generic Low-Latency ASIO Driver.

Hi. Thanks for the reply. I tried what you suggested after a complete uninstall and reinstall of Dorico / Halion / Library Manager / Download assistant and all Halion content. I even deleted the steinberg / dorico files in the Registry. There is still no sound or midi in Dorico OR Halion (either as a standalone or within Dorico). Using the mouse on the keyboard in Halion produces no sound or Midi and the track sound still shows a little red cross on the track within Halion when I try to load it.

I’m reluctant to use a different driver as all my other programs work fine. I use this computer for teaching over Zoom and don’t want to change anything as it took ages to set up correctly.

I’m not sure a different driver would make any difference because the problem seems to be with Halion. The mouse click on the piano within Halion (either standalone or within Dorico) yields no audio or midi activity.

Anyhow, I have attached the saved Dorico project as you suggested. Thanks for taking the time to look at this. Cheers Jon
Dorico Test.dorico (580.9 KB)

The project you’ve attached plays back just fine, so that suggests that the sound content and the HALion Sonic SE plug-in are all installed correctly. You should find that installing the FlexASIO driver has no impact on any other applications on your computer, but I can understand your reluctance to interfere with an otherwise working system.

Have you been through the playback troubleshooting video?

(There’s a transcription of the text of that video a couple of posts further down in that thread.)

Hi again. Yes I have already watched this video before asking for help. None of the solutions cover my issue. Everything is installed as per video. However, the video doesn’t cover when there is no sound or midi in Halion when the mouse is dragged over the keyboard at the bottom of the Halion GUI. It assumes there is both midi and audio activity in the meters and midi indicator. I see neither. It then goes on to other solutions. This is no use to me as there is no sound even reaching my sound card from Halion. Cheers Jon

Unfortunately I’m at a loss, Jon. I’m sure my colleague @Ulf will be able to help when he returns from his holiday in a few days.

Thanks. I hope so. Thanks for your help so far. Jon