Dorico through Digi002

Dorico 3.5 doesn’t playback through my Digi002. Is there anything I can do about it?

Did you go already to Edit > Device Setup? In the list of drivers there, is there an appropriate driver for your device listed?

Please also do Help > Create Diagnostics Report and attach the corresponding zip file here. Thanks

Yes, Digi002 is listed (see att.) The mixer is showing nothing during playback, but I can hear sounds when I play on Halion Sonic keyboard by mouse in Play mode.
I am sending the Diagnostics report too.

Dorico (653 KB)
Device Setup.JPG

So at least you get already sound through, even it is only by playing with the mouse on the HALion keyboard.

When you press play, does the green play cursor move?
Try following: Go to Edit > Device Setup and in there change the sample rate to 48kHz, wait for 3 seconds, then switch it back to 44.1kHz.
Close the dialog and try playing back. Is it then doing?

Yes, the green play cursor moves when I press play.
There is only one option in the Sample Rate dropdown menu: 44100. I am not able to change it to anything else.

I restarted the Digi002 and now I can switch the Sample Rate to 48kHz, than back to 44.1kHz, but still no sound.

I can also hear the sound during note input and selection.

Okay, in that case you probably don’t have a proper endpoint setting. Go to Play mode and then choose from the menu Play > Playback Template and then the HSO template.
That will reload all sounds and setup the proper mappings.

I’ve reloaded the HSO template, but it doesn’t help.

Strange, that if I choose Generic Low Latency ASIO driver instead of ASIO Digidesing Driver FW002 it plays back without any problems.

If I choose ASIO Digidesing Driver FW002 with the same HSO template (I’ve also tried the NotePerformer), I can here the sound when I write and edit in both Write and Play modes. I can also hear the sound when I play on the HALion Sonic keyboard, but I cannot hear any sound during playback in any mode.

In that case I don’t know further either. I see no reason why sound should not come out also during playback. If during playback you have the HALion Sonic editor window open, is there any indication of MIDI notes reaching HALion? In the left top corner of that window is a red “LED” that should flicker on every incoming MIDI message. Is it flickering?

When you say it works with the Generic ASIO driver, does sound then also come through your Digidesign device or through built-in speakers?

There is no any indication of MIDI notes reaching HALion in HALion Sonic editor window during playback. The indicator is active only during writing and editing.

Yes, with the Generic ASIO driver active, the sound comes also through the Digidesign rack – headphones output.

That is strange that no MIDI gets sends. But of course, in that case also no sound will get generated.
To be honest, I don’t know what is going on then.

But if it does work with our Generic Low Latency driver, then why not simply use that one? Because of the driver the sound won’t be better or worse, so just use what is working.

Thank you, Ulf, for your effort. Perhaps only one more question: Is that normal, that the plugin (HALion Sonic SE) becomes deactivated when I start to write or edit notes in Play mode?

What do you mean with deactivated? You mean that it disappears? That is normal, but the plug-in as such is still active and processing audio.

I mean that the Activate Instrument button loses its color. (see att.)
Activate Instrument.JPG

Oh, that is not normal, no. While in that state, could you please do Help > Create Diagnostics File and post the corresponding zip file here? Thanks

Actually I think that’s just a cosmetic issue, where the plugin is activated, but the button state isn’t updated to show that it is.

I’ve just noted that the same behavior (Activate Instrument button loses its color when writing or editing in Play mode) is when I use the Generic ASIO, so it seems that this cannot be an issue connected to my problem with playback through Digi002.

However, I am sending a Diagnostics File for sure.
Dorico (338 KB)

I can confirm that it’s definitely not related; it is indeed a cosmetic problem, caused by a mistake in how the user interface is updated when the selection changes. Strangely enough we fixed that problem in our development builds just this week.