Dorico Time Signatures bugging out


Recently Dorico’s time signatures have been bugging out for me. I’m assuming this has to do with the font selected for the time signatures; however, when I originally made/worked in these files, everything was fine. Using Narrow Sans-sarif within the display option, and I am using Arial Black for the time signature fonts.

Additionally, new flows appear to have invisible time signatures, as well.

Hello there Pete, If you’ve changed the ‘Time signature font’ style, have you made sure that the new font you’ve chosen is SMuFL-compliant so that Dorico can correctly locate the required glyphs within the font?

Yes, you can’t use an arbitrary font for time signatures unless you also choose Plain font in the option shown by Lillie in her reply. Then you need to set Time signature plain font to your chosen font in Engrave > Font Styles.

I tried switching it back to the default of Bravura and then to Time Signature Plain Font; however, I still end up with the random symbols in the window.

They are displaying correctly on the page, but it is only the window that appears to be having an issue. I have returned the time signature fonts and settings to the default–to no avail.

Might be worth a system restart.

Ya, it took a few tries before everything got back to normal.