Dorico won't load properly

I have recently had occasion to clone the hard drive of my main computer to my laptop while the main computer was away for repair.
I have run Dorico succesfully in the past on the laptop in its original state as I use a USB eLicenser which I swap between machines.
This time with the cloned drive I got a message saying that the eLicenser software needed upgrading, which I duly did and checked that that my licenses were recognised.
Dorico1.png
However, when I came to load Dorico it appeared to start(revolving circle for a short while) but nothing appeared on the screen. When I checked with Task Manager, Dorico appeared to be loaded in the background but not as a running application.
Dorico2.png
I then checked with eLicenser control and it didn’t show any valid licenses.
Dorico3.png
I have tried uninstalling and reinstalling both eLicenser and Dorico but get the same result.

I would be grateful if anyone can help me with how to proceed to restore Dorico on the system.

Sorry to hear you’re having problems getting Dorico back up and running. My first suggestion would be to use the Soft-eLicenser reactivation process, which should allow you to get a new activation code so that you can get Dorico back up and running again. Log in to your MySteinberg account, and you’ll see a big red ‘Reactivate’ button at the top of the page: click that and follow your nose and hopefully all will be well.

Thanks for your input on this Daniel, especially at such a busy time. I finally got Dorico to load properly by (as your suggestion) deleting the Steinberg folder in %appdata% and reinstalling Dorico from scratch.