Dorico won't play via Bluetooth earphones on PC

Hi

I am having a problem with playback. Instead of playing through my OnePlus Bullets Wireless 2 earphones, the audio is coming from the internal speakers on my Windows PC. I have searched all over Google and this forum for any answer, but can’t find any. The earphones works fine in all other applications, it’s only in Dorico that it won’t play back.
The earbuds aren’t showing up under output or input ports in Device Control Panel. Also something to note, is that the only sample rate i can choose is 48000, while all the tutorials I have watched suggest i should use 41000. But I can’t choose that. Does that have anything to do with the problem? Just bought Dorico Elements today, and it’s really sad that I can’t use it at it’s full potential. I could use wired headphones, and that works fine, but it would be nice to have Dorico working with Bluetooth earphones as well.

Thanks

Håvard


This thread might help. Read the whole thread, not just the post that solved the problem.

https://www.steinberg.net/forums/viewtopic.php?f=246&t=109251&p=828661&hilit=bluetooth#p828661

Thanks for the link Rob, after a lot of trial and error, I managed to sorta fix the problem. What I needed to do was to install ASIO4ALL, and change the bitrates in the settings to 44,1hz. Then I needed to update the Windows drivers. After that I managed to get playback in Dorico. However, I have to close Dorico when I want to watch Youtube or listen to Spotify. But I guess that’s the price you’ll have to pay. Thanks again Rob!

Håvard

Now that you have switched to 44.1kHz, what if you switch back to the Generic Low Latency Driver?
I’d expect it to work now.
Furthermore, you should also be able to get sound out from Dorico and YouTube at the same time.
I have a pair of JBL BlueTooth headphones here on my Win PC and it does work with the Generic Low Latency Driver.

When I switch back to the generic driver, the only bitrate that shows is 48kHz. Thus, I am not able to get any sound from Dorico. I am however able to hear sound from Youtube and Spotify. Do you know why only 48kHz is showing up when I use the generic driver? When I switch to ASIO4All driver, I’ll get sound from Dorico, but not from Youtube.

In the Windows taskbar is a little speaker icon, right click on that and choose ‘Open Sound Settings’.
At the top of that new window, choose your BT phones as output and a little below press ‘Device properties’.
Again, a new window opens and in there choose the ‘Advanced’ tab.
What is there the default format set to? Can you change it?

I tried the steps you provided, and got to this screen (See SS). The bitrate is at 44.1kHz, but I can’t change it.
When I do the same with the internal speakers, I get two options, but they are both at 48kHz. I think the problem is that these values are not the same. But I can’t seem to change this. Do you know what I could do?

Thanks

Håvard


Hm, your’s a difficult case. Try unticking the other options, ‘Tillat programmer…’ and see if then more options appear. Also, stop any audio application while doing this.

And what if you use the ASIO4All driver, can you then change the sample rate?

As you see, I don’t have the definitive answer, but somehow fiddling with the options must make it happen.
It works with my JBLs here, so it must always with your OnePlus’.

I have a similar problem. Initially, couldn’t get any sound from Dorico. Went through every step in the troubleshooting video, and still no sound. Then it occurred to me that one of the steps, setting the sample rate to 44.1 wasn’t possible - only 48 was an option. Eventually. I matched the 48 in the advanced settings and I could hear Dorico at last!
However, I have BT headphones (Bowers & Wilkins PX), and I cannot get them to play either - or a BT soundbar. Only output is through laptop speakers - they’re Bang & Olufsen, but still pretty tinny compared to them.

It seems like the only solution I have is to use wired headphones. That fixes all the problems I have. With the BT headphones I was also having MIDI recording latency, which is gone when I’m using wired headphones.

BT headphones are not in general a problem. I have here a JBL T450Bt and a Sennheiser HD4.50BTNC and they both work as expected together with Dorico, on Mac and Win. We can’t get hands on every model and guanrantee that it works with every available headset out there.

The increased MIDI latency most likely comes from bigger ASIO block sizes when using the BT headphone.