Dorico won't select audio device...

Ulf, I’m sorry…

The extra slash shouldn’t make a difference.

Could you try just:

open $TMPDIR

Is there a folder called VSTAudioEngine in there?

Ok, that opened a folder, what am I looking for in said folder?

Another folder called “VSTAudioEngine”

As you can see, there is no such folder…
T Folder.png

Then it looks like that the Audio Engine doesn’t have the access right to write to that folder.
How can that happen? Well, from difficult to impossible to diagnose from remote…

What would you suggest? It seems that Dorico is in beta stage at best.

I’m sorry that you’re experiencing these issues. We’ve been in beta for a while and haven’t experienced this issue so far in over 200+ installations.

Is your user account on your Mac set to Administrator level?

Have a look… (18.3 KB)

I was looking at an HD in Finder, and it indicated that the administrator had read/write privileges. When Get Info about Dorico was selected, administrator was read only. I have two other Steinberg products, and they were both read/write for the administrator by default.


When I choose the audio device it still won’t stick, but these temp files appear in folder T.
Temp files in folder T.png

Aha - that’s good, they’re there. I’ll let Ulf download them when he’s back in the office and follow up.

Okay, from the log files I can see that the engine is always trying to load another driver, but then immediately switches back to the built-in audio driver. We haven’t seen this before.

Further, I don’t know any of the other drivers that you have installed. Do they work together with dedicated hardware or are maybe some “soft” drivers, e.g. for networked audio?

I see from the log that the sample rate is set to 48kHz. Do your other drivers support that sample rate?

The drivers are as follow: AJA driver is for a video card. The Advanced USB driver is for an optical drive, and Symphony driver is for my audio card. Yes, they all support the 48kHz sample rate.

I found that all I had to do was relaunch Dorico for the changes to take effect…

Yes, I have tried closing and relaunching from the beginning, it makes difference. Ulf, is investigating the issue, hopefully…

Yes, we are, but still at no grips…

Stupid question, but the Symphony card works with Cubase or WaveLab, sure will do, right?
When you run Dorico, is still some other application maybe holding on to the Symphony driver?
Could you try closing all other apps and then launch Dorico, still the same?

Ulf, Cubase and Wavelab have played nicely with the Symphony driver for many years, there are no other apps. running…


We can’t reproduce your issue and can’t find something obviously wrong in our code. Internally I’ve logged your issue in our bug base [AD-243], so we will continue investigating. Unfortunately it is uncertain when we will have a solution.

Ulf, my system is hardly unique. I don’t mind participating in an experiment, typically there are disclaimers for such scenarios, they’re called beta tests. The crazy thing is, Steinberg and the Dorico team contacted me months ago and asked for beta testers, I agreed, and was completely blown-off by Steinberg, never a word… Now that I’ve paid for Dorico with my hard earned scratch, we find issues that should have been discovered long ago and these issues are preventing the most basic functions. Please don’t misinterpret, I whole heartedly support your, and your teams effort, we need Dorico. I have been working in Cubase score editor for several years now, it’s not unusual to create a hundred and fifty page score, I know how unwieldily the work flow can be with a decent, albeit, limited score editor. Please don’t ignore this issue, I’m willing to help resolve it…