Dorico won't select audio device...

I am trying to select the proper audio device in the Dorico Preferences, but Dorico always defaults to the built-in Mac audio device. Any thoughts?

JM

There is a bug where you may need to select a different device and then exit and restart Dorico in order for the new choice to take effect. We’ve fixed this and it will appear in the next update.

That doesn’t work either… Any other ideas?
JM

Uhh, when will you release the first update? I am dead in the water if I can only use mac’s core-audio. The ability to select an audio set-up seems to be pretty basic functionality, yes?

JM

I’m very sorry you’re having problems. Which audio devices appear in the list, and which one(s) have you tried to select?

No matter which device I choose, it always defaults to core-audio… Saving makes no difference.

JM

Audio Devices in Dorico.png

That’s very odd. Could you find the VSTAudioEngine folder in ~/Library/Application Support/Steinberg, zip it up, and attach it here?

There is no VST Audio Engine folder in Application Support> Steinberg.

I beg your pardon, it’s ~/Library/Preferences/VSTAudioEngine. Sorry for the misinformation.

VSTAudioEngine.zip (1020 KB)

I will ask our audio engine team to look at this data and hopefully they can advise.

Is this going to take awhile, Should I shut Dorico down for the time being?

JM

Well, the audio engine team are asleep in bed, where I should be since I literally have a plane to catch in the morning, so I’m afraid the earliest you can expect a reply is sometime tomorrow (Thursday). I’m sorry that I’m not able to provide more instantaneous support on this occasion.

Understood Daniel, no doubt you have your hands full. I’m looking foreword to using Dorico, I admire the work ethic of you and your team. You have undertaken a daunting task, with demanding masters.

JM

Hi JM,

indeed, weird behaviour that we can’t explain by now.

Additionally, could you please zip up the contents of following directory:
$TMPDIR/VstAudioEngine

There are one or more log files of the audio engine in there. These are more useful for us to look at.

Cheers,
Ulf

Ulf, where might I find said directory?

JM

If you open the Terminal app and type…

open $TMPDIR/VSTAudioEngine

…it should open a finder window at the right place.

Terminal.png

Weird, should work straight away. But in the error message is one slash too much.

So in the Terminal, could you please manually change directory to that place but leave out one of the slashes?
In other words

cd /var/folders//T

and then do

open VSTAudioEngine