Dots not hidden?

I wonder why dots are not hidden if I use the Property color/opacity!

Only noteheads, and no other fragments of notes, are affected by the Color property. If you need to be rid of a rhythm dot, probably the best approach is to make the notehead undotted, and then remove the rest that appears.

1 Like

And just to make sure, you’re aware of the fairly recent “Hide notehead” property?

Yes; in my case I wanted to hide dotted pauses in an open meter; I found the solution by splitting the pauses into non-dotted ones and then hide them as Daniel mentions; but I wanted to suggest to modify the color-feature in a future version so that it affects also dots, since my procedure is not very “elegant”…

And then, what are we to do if we want the dot but not the notehead?

This feature works well as is, thank you very much. If you don’t want the dot, use “hide notehead” or Daniel’s suggestion.

Who would want to show the dot of a hidden element? :flushed:
As I mentioned to Lillie, I have to hide rests, not noteheads. „Hide noteheads“ does not work here!
Daniel‘s suggestion works, but it is a workaround, not a „solution“!

Someone. Someone always wants to do something that you might otherwise think is not likely/meaningful/standard. :grin:

Can you show us an example, in case there’s another method of achieving what you want?

1 Like

Me

image

OK, I see, in this case you are right. But this is a perfect example of hiding noteheads.
I was talking about setting the opacity to 0.
I don’t know if it is technically possible to separate the handling of the two; if yes, this would be the solution.