"Down Bow" without sound in playback

Violin Solo Combi: Notes with „Down Bow“ will not play, no sound in playback.
DownBow.zip (767 KB)

Ehem… One rule on this forum : search before you post… This one is several hours old : https://www.steinberg.net/forums/viewtopic.php?f=246&t=133283

Is right, you are right, I have overlooked.
It was almost at the same time.

This seems to be a totally random bug. Last nite I tested the attached file and the marked note didn’t play. Just now it played (fresh download). I managed to make a new file where the downbow didn’t play. I then removed the previous 2 bars, and the downbow played. I then undid the bar removal and the downbow still played… [!]

“This seems to be a totally random bug”.

Indeed! And that makes it exponentially harder for developer to track down and fix.

I’m experiencing a similar issue, all notes marked with upbow or downbow are not sounding. Not managed to get them playing yet tho’ :slight_smile:

Ok, so I’ve found the same bug in another piece, and this time I can see that the bar I use to start playback (e.g. bar 67, 68, 69, or 70) will cause different combinations of upbow/downbow notes to be missed later in the piece (i.e.in bars 71 and 72). And if I start from bar 65, I hear all notes in bars 71 and 72, but not if I start in bar 64 or 66.

Hope this helps track down the problem.

I feel rather puzzled by the absence of any reaction from Dorico’s team; even simple “sorry, we couldn’t reproduce that problem” (which would be understandable, given apparent randomness of the bug).
Just in case somebody from the team is willing to look into the issue, it should take just a couple of minutes - compile a few measures of solo violin music and apply a few bowing marks.
If it matters, I’m on iMac 27’’ 2.8 GHz i7 8GB RAM High Sierra; using HALion Sonic SE
Igor Borodin

Igor, I also think that.
There is bad Support and there is a good Support.
The actions decide on it.

I’m sorry that we haven’t got back to you before now - it’s hard for us to keep up with everything on the forum.

I did take a quick look at this last week and couldn’t reproduce the problem, but I’ve taken another look today and it appears that something strange is going on in HALion Sonic SE. I’ve exported a MIDI file of this score and found that the note doesn’t sound in Cubase either. I’ll log this internally. If you have a specific note that doesn’t sound then a workaround to try is to switch to Play mode and drag the start position of the note a very small amount to the right.

Thank you, Paul. (I know firsthand that inconsistent bugs are hardest to fix :slight_smile:

Probably an easier and more reliable workaround is to use a VST2 playback device. This looks like the VST3 timestamping race condition we saw with Pianoteq6 and with keyswitching at the beginning of a flow.

Thank you for the idea; although going with VST2 may present its own surprises - e.g. somebody on this forum (I can’t recall the specific thread) reported a problem with double-stops not played back with VST2.
Still, the more options - the better!

Here are two MIDI traces.

The Downbow trace shows if downbow is specified then you get a NoteOn for keyswitch F#0 at the same timestamp as the NoteOn for note E4.

The No Downbow trace shows that if no downbow is specified, the timestamp for the NoteOn for keyswitch F#0 is specified earlier than the timestamp for the NoteOn for E4.

In the case where both notes have the same timestamp, in a VST3 player (e.g., Halion) you run the risk of reversing the order of the noteOn events. This is because VST3 devices process multiple MIDI streams in parallel so there is a race condition for any events that have the same timestamp. If the NoteOn for the Keyswitch comes after the NoteOn for the note, then you clobber the sound that E4 would produce since there is no sound mapped the keyswitch note.

VST2 players will not reorder MIDI events since they can only process a single MIDI stream. So if they are presented to the VST in the expected order, then regardless of timestamp they will be processed in that order.

Hi Piano-EK,
with the help of your MIDI file I’m able to reproduce the problem here.
There is indeed a time frame of 1-15 ticks were no sound is played if the note-on of the key-switch comes beyond the note-on of the playing notes.
Its now in our Defect-Tracking-System and listed as Bug-ID “HALLY-7338”.
I hope we can provide a fix for it soon.

Thanks for your report and please accept my apologies for any inconvenience caused.
Gerrit Junge

Remark: To avoid problems, a key-switch that switches between articulations should be triggered before the corresponding note(s) because once a stone has been thrown one can’t change its direction.

It is a good message.
Thank you for the investigation and for the technical information.
I am glad that for all affected persons the violin will better soon play.