Download and VST Problems

Greetings All,

We are having two issues with Cubase 10 Elements. Please help if you can. I bought Cubase 10 Elements for my husband for Christmas, but it has never downloaded right. We have had limited time to figure out what we need to do to make it work because of my job, which is why I’m just now getting this message out to the community. I initially tried to download and install in January.( We are using the eLicenser, if that makes a difference.)

  1. The download in January worked for the basic program itself, but we didn’t have any VSTs other than Prologue. I read some support postings and determined it was a botched download. Based on several postings from people having the same problem, I thought that we needed to re-download the program. The program opened and worked for the most part, but we didn’t have all the free VSTs that Steinberg boasts about.

  2. Based on the support messages I saw on this forum, I uninstalled everything with the intention of re-downloading and re-installing everything to get the VSTs. I assumed the first download skipped a beat and that was why we didn’t have any additional VSTs. But now the program will not download at all without problems. Now every time I try to re-install, I get an error that the file is corrupt. I’ve done this repeatedly. So now we don’t even have the basic program with Prologue like we had in January.

We are working with Windows 10, a relatively high powered machine worthy of gaming. So Cubase is not too much for the box itself. But we can’t get it to download completely and include the VSTs.

I realize it may be a little old-fashioned, but it seems like if we could install from a CD this whole process would be simplified. It is very difficult to diagnose the root cause of the issues when we don’t know for sure that the program downloaded entirely. Our internet access frequently experiences hiccups that are out of our control.

Also, please note that prior to uninstalling, I tried to find the VST files to install. I did find some files that had the .aria extention, but they wouldn’t open and install. Is it possible there is a problem with a third party program?

Bottom line is that we’ve been spent money on a software program that we are unable to use. The program will not download, and the last time it did download, it wasn’t complete. Not to mention that I bought this as a Christmas present, and here we are in June and it still isn’t working.

Please help! What can we do to make this work?

Bill’s Wife