Download assistant loop loop loop

I have seen this problem on an old forum with no solution that has worked for me. I have to download a copy of Cubase AI and then upgrade it but I cant even download Cubase AI. The download assistant loads up a page where I sign in and this tells me that I need to authorise the download assistant, which it doesnt give me an option to do! Help!

What browser are you using? After signing in to your MySteinberg, you should get a notification near your address bar about your browser attempting to run the Steinberg Download Assistant.

Make sure that you’re not running script blocking extensions, or try temporarily setting another browser (Edge, Firefox, Chrome…) as the default browser.

I’ve tried Chrome, Edge and Firefox all with same frustrating results!

I tried setting each in turn as the default browser to no avail. I’m now a bit further on as somehow I managed to download AI without the downloader (don’t ask me how!) I’m now downloading the upgrade to Pro 12 manually module by module without the downloader. I hope everything will work!

You can redeem your download access code from your MySteinberg, but it’s strongly recommended to get the Steinberg Download Assistant working. You’ll probably have issues signing in to the Steinberg Activation Manager too.

This is what the authorization popup looks like on Edge, at the top. Are you sure you never got this or a similar message while using any of your browsers? What happens if you reload the page? Do you have some third party antivirus installed, and have you tried disabling it or any intrusive “browser security” features it might have?

Thanks for your suggestions and helpful screenshot.
I’ll give this a go soon.

Thanks again.


Hi again.
I’ve set up Edge again as my default browser and checked that I haven’t any extensions. I then launched Steinberg Download Assistant from the desktop icon, but I just get back to the loop again!

Everything downloaded but now it needs an activation code! Where do I get this?

I’m no further forward. Do they pay people to make it deliberately obtuse?

The problem here is that there’s something about your computer that’s preventing the Steinberg Download Assistant authorization from completing. Activating is normally a 2 or 3 step process.

What’s your operating system, is it fully updated?

If you’re in the UK, you could try calling Steinberg Support tomorrow. They should be able to help:

Thank you. The phone call did it and I’m up and running, (well crawling at the moment!!)
Thank you for all of your suggestions. Have a great week.

1 Like