Download Assistant still NOT WORKING!

Hello,

I have raised this issue for weeks when trying to get Groove Agent which I still don’t have.

Took a leap of faith for the 10.5 Cubase update and now cant install because Download Assistant wont boot.
Not Happy.

Please Please Advise the sound of crickets and silence is killing me!
My system is Windows 10 all up to date.

To add I have just gone an updated e licencer which doesn’t seem to make a difference.

Anyone??

Had the same issue. I’m in Australia. The thing that worked for me is this:

  1. Get a VPN, there are free ones out there. Just do a Google search
  2. Set your VPN in another IP location, preferably in a different country
  3. Download the Assistant and just to be safe download the 10.5 update. The VPN’s work is done. You can exit the app.
  4. Re-install the Assistant, open it and try to get the 10.5 update
  5. If that fails then just install the update that you downloaded manually.

Hope that helps

Thanks will give it a go. I’m in Australia also.

@ tc7four - Had the same issue and VPN method worked. Thanks!

I am in Australia too. Download assistant works, but updater is not working. Seems to be a common problem.

So I worked out how to get it going, on my PC at least…
Install latest JAVA version… install Download Assistant.
Navigate to: C:\Program Files (x86)\Steinberg\Download Assistant\app
Click on the Steinberg Download Assistant file - which should have a JAVA icon… and it worked. Looks like the App link is screwed up or something.
But it worked for me.
Good luck.

Thanks and good to hear it worked. I couldn’t get it to work. I Ended up doing the direct download and now have 10.5 up and running.

If I’m not mistaken isn’t JAVA about to be unsupported by Windows soon? Either way Steinberg Techs need to get this issue fixed instead of leaving the end users in the dark :unamused:

My solution…
I used Tor browser to log into Steinberg.
This browser obfuscates your ip address, so downloads proceeed as normal, files are not corrupted.

Try it.

Nice solution.