Download Errors


Sorry if this has been mentioned, but I’ve scrolled through the other posts and can’t find it yet.

I just bought at product that came with a free download of Cubase. I followed the instructions, inputted the download access code and it was recognised and accepted. I was told to click a link to begin the download.

However the download link that Steinberg provided doesn’t work at all. I’ve seen on my profile that it’s registered but not activated. None of the links work - nothing at all happens when I click. Furthermore I’m told the access key has now been used so I can’t even restart the process.

In addition, the support request page on this website has a major issue - you can’t submit the form without selecting a product. However the drop down list has no options in it and you can’t type in the box. As such it’s impossible to successfully submit a support request.

I’m really disappointed. I’ve been back to the shop where I bought it who are say I have to take my problem up with the software providers.

Any help or advice would be much appreciated. I’m on here because it doesn’t look like there’s any other way of getting in touch with Steinberg short of trying to make an expensive international call (their UK number seems to be in Ireland or somewhere).



I stayed up till the small hours working out various issues with Cubase. I made adjustments to my web browser (i.e. using a different one) and successfully downloaded a version of Cubase. I’m guessing there was something up with the security restrictions or download options on the browser or something that I couldn’t find, which is weird because I’d never had problems before but yay - that’s one problem solved…however the problems don’t end there.

I downloaded and activated Cubase and all credentials were accepted. However as the download was ‘Cubase Elements’ and not the full version, I was led to believe that activation would see it upgraded to the full version, as promised. However today I continue to get messages telling me that the software soon won’t work or that I need to pay more money to upgrade to the full version…money I’ve already paid by buying hardware inclusive of a full version of Cubase.

On top of that I’m still pushing through trying to get the drivers to work. I’m definitely using the most up to date versions. I’ve managed to get Cubase and the hardware I bought (Zoom R24) to talk to each other, setting up mackie controls etc. However I still can’t get the output sound to work. The Zoom R24 is picking up signal from the computer generally (e.g. You Tube vids) but not from Cubase. I’ve ensure the right Zoom drivers are active, but it’s still not picking up the output channels. How can the Zoom pick up sound from the computer but not when it’s from Cubase?

Any ideas would be much appreciated. Meanwhile I will push on and hope I can solve the issues with perseverance. I’m about to try a different speaker set up using different output channels on the Zoom R24 to see if that makes a difference.

Hope there’s someone who’s seen this before, or can link me to a thread that deals with it. Thx.

What type of Cubase do you have? AI? Elements?

I can’t remember a hardware that would include a full license of Cubase pro. I think most of hardware includes the AI version. Maybe you are using the wrong version as a demo (AI is not the same as elements)

Hi, Thanks for your reply. :slight_smile: I was supposed to get Cubase LE 8 (full version) but ended up with LE AI Elements 8 (at first), which I think I’ve successfully upgraded to the full version after activation. It seems to be working, but I still get regular prompts to buy what I already seem to have. I’m thinking it’s because the full version was updated from a demo n something’s lingering. I hope I don’t get problems further down the line.

In better news…I’ve made progress! Huzzah. And I’ve done so much troubleshooting I could do a You Tube vid. I’ve actually got to the point whereby I’m trying to record tracks…my ongoing issues are…

I’ve got an electro-acoustic guitar sound coming through the Zoom R24, got the levels right etc. Record button on Zoom R24 is syncing with Cubase so the mackie controls are working. There also seems to be a visual signal reading on Cubase (on the bottom bar where play is), suggesting the sound is getting through. However nothing records. The record button works but no sound is laid down. I’m definitely playing guitar. I can definitely hear it in the headphones. I can see the sound registering on all but the track I’m recording, and playback yields nothing.

I’ve checked that mutes etc are off. I’ve checked that the right tracks are allocated to channels etc. I’ve checked the device drivers. It all seems to be working but no sound…I will find the answer though. Any ideas would be appreciated!

Also does anyone else find it annoying that you can set it to release drivers so you can watch you tube or something (which is great), but it’s rubbish at picking it back up again afterwards? I have to shut Cubase down and restart to get any sound back - closing the interupting window makes no difference. Ideas there would be appreciated too. I’ve already ticked the ‘release drivers’ box - it’s going back in that’s the problem.

Also sorry that this thread seems to be diverging from just download errors. I’m hunting through the forum for the answers to the above and if I find them, I’ll share them.

Thanks! :slight_smile:

I managed to record something YAY! I don’t know what I did but it worked. Hopefully I’ll find out.

It sounds terrible though, proper tinny…I’m going to have to master effects now I guess. It sounded great while recording but playback was a shocker.

I’m thinking I’m nearly up and running though. Thanks Forum Folk. Just you being there helped.