Download Manager fails to download Iconica Ensembles

I’Ve been trying for almost 7 hours now to download Iconica Ensembles by using the Download Manager.
However, again and again the Manager seems to “freeze” after a while, i.e. stops downloading. When I then press the “interrupt” button (i hope the translation of my German language version (where the button is called “unterbrechen” is correct) the prgram does not react any more and I have to reboot the PC. However, the download then obivously does not continue from where it stopped (let’S say the previous download stopped at 8 GB (according to the figure shown in the Manager) it’S starts again at a lower figure (say 6,5 GB).
Numerous reboots did not help to finish the download (still miles off the 50 GB)
Anyone knows what I can do?
The download section of the Steinberg HP obviously does not offer an Iconica download option, so using the Manager is obviously my only option.
I would be greatful for any advise

How long did you wait until you pressed Unterbrechen?

The download manager internally uses a software that seems to work on chunks. So if you successfully downloaded already 6.5GB it will start at the position when you restart the download, regardless of what the display showed, because that chunk was not completely done so far.

Btw. rebooting the computer doesn’t help at all here, if the download basically works. What kind of internet connection do you have and what provider? Did you try to do a speedtest like , just to see what the connection says?

Hi Juergen,
thx for your reply and advice . I left the PC turned on overnight and the download now stands at 23 GB
I am currently located in Singapore, so provider name most likely will not ring a bell for you (it’s Starhub, I can tell you I was much happier with 1&1 back in GER :slight_smile: )
Acc. to the speedtest link download speed is currently (local time 10 am) at 573 Mbps, download latency at 11 ms

Anyway, if I understand you correctly pressing the UNTERBRECHEN button, i.e. interrupting the download , then closing the application and then restart tonight would not harm, correct?

Oh, I know Starhub :slight_smile: Been to Singapore some years ago myself…

So the download link doesn’t look too bad, but that also doesn’t mean it has the perfect connection to the Steinberg servers. However it seems to proceed.

Correct. As an example I just tried to download a package via the SDA and stopped it.

As you can see it has app. 900 Megabyte downloaded and when I press Fortsetzen it shows this.

However, what I’m not sure about is what happens if you change the provider or the IP address is changed. This might have impact on the continued download.

Hey there, I am having the exact same issues, I have tried downloading the product 6 times now and it fails every time, the last time it got to 25 gig then failed, when I retry it starts at the beginning again.

I am on an Mac M2 pro 16 gig ram plenty of hard drive space
can any one help as I need this for an upcoming project pronto
The Track factory Ltd.