Download manager throws unknown error


I’m hoping someone here can help as Steinberg support are completely ignoring my ticket.

The download manager throws an error. I’ve followed the trouble shooting guide which made no difference. I’ve seen some say to make sure your time is set. I’ve done that using NTP. Still no luck.

Has anyone experienced this before and if so did you find a solution?

Thanks in advance.

any more information on the error ? apart from it being an ‘unknown error’ ?

This is the only clue.

I’ve done everything that is suggested at the help centre. No dice…


I think that’s the download assistant updating itself.

I’d suggest you download the latest version and install the update manually.

Thanks for that.
I’ve tried it twice already.

and what happened - same error ?

try uninstalling and reinstalling

Thanks again.

Yup. Exactly the same.

I pretty much uninstall everything and then reinstalling. No difference.

just checking

you uninstall
download the LATEST version from the link above
and when do you get the error ?
is it EXACTLY the same error - “an error occurred during the update process”

and can you update the elicencer software too ?