Download manager VST updates render older projects invalid

Updated halion sonic, groove agent etc from the download manager.

Now projects that previously used those plugins can no longer find those plugins.

Is there a fix for this please


What do you mean by that? Do the plug-ins not show up? Have you tried installing them again?

Cubase’s VST updates render any projects that used the pre-updated VST unusable as they become invalid plugins.

For example using imaginary versions and projects for simplicity:

Project-A uses Halion Sonic SE v1 and was created in Cubase Pro12. Download assistant provides an update to Halion Sonic SE v2. Project-A now no longer recognises Halion Sonic SE v2 as a valid VST - So it doesn’t load, and its not possible to save the data that was made in HalionSonic SE v1 AFTER updating to HalionSonic SE v2 whilst the HalionSonic SE v2 is installed. I assume a work around would be saving the instance of HalionSonic SE v1 as a preset & opening that in HalionSonic SE v2. The issue is if you have hundreds of projects that use HalionSonic SE v1, opening every project isn’t a liable method. Or Project-A could be opened in an older Cubase version at which point you lose all of the new features you used from Cubase onwards. Or simply remove the updates & use the older versions - continuing to use C12pro

This only ever happens with cubase VSTs. Another issue im facing at the moment is Some library licenses not being active such as Olympus Choir

Halion Sonic SE 3 is backwards compatible with all previous versions. Try restarting your computer, uninstalling all versions of Halion Sonic SE present in your system, then downloading and installing the latest version using the Steinberg Download Assistant.

If you’re coming from an old version of Halion Sonic SE (such as HS SE 2), it might make sense to also download the content to make sure that you have the latest versions of everything.

If you’re still having trouble, please open one of your old projects and take a screenshot of the Track Inspector of one of the affected tracks as well as the Halion Sonic SE plug-in window.

1 Like

ill give this a go now. Is there a proper way to uninstall or just remove the vst files?

If you’re using Windows, please search for “Add or Remove Programs”.

1 Like

Im still getting erors
and now its not recognising Groove Agent SE either

also ive noticed the new C12 update removed itself somehow - its showing 12.0.50. So things def aren’t being installed correctly.
I do still have Cubase 10 & 11 installed, do you think that could be the issue?

Did you do this:

Please do just what’s written there. Nothing else. Not even a smoke break. You know what I’m saying…


I’ve done this, but the result was what I posted earlier. Before I left out to the studio I did it again but this time didn’t reinstall the updates for the VSTs . Im at the studio now and fired up my machine but
halionsonic is still missing unfortunately

I don’t think so. You should get in touch with support, maybe they can help you. What you’re saying in your posts isn’t really making sense.

Maybe you’ve got the names and versions of the programs wrong, but we can’t help you if we don’t know what you’re looking at.

This is what I’m seeing now…

halionsonic isn’t present, is there any chance it’s been installed to an incorrect folder, especially because it’s VST3. That’s the only thing I can think of. I’ve followed all the steps that have been listed.

Also, I’ve opened a new project and now cubase has reverted back to version number 12.0.50… moment ago it was the latest update. I have no idea what’s going on.

If you don’t feel like doing the steps asked from you, no problem.

Have a good night.

I’m confused, what steps are you referring to?

I uninstalled the plugins and reinstalled them. But it didn’t help. I restarted my computer etc. I think you’re misinterpreting how I’m coming across. But your last comment just seemed rude & I don’t think I deserved that. You’re saying reach out to support; which I’m going to do. I just wanted to share the new images with you to see if they gave anymore insight into my issue. I’m at the studio right now - IE not at home and its 3AM. and support will take days to reply. All you’ve done is dismiss & talk down on me. Thats not mod like at all. no thanks

Id rather just hear back from Romantique_TP I wont be responding to you steve. odd behaviour

Your screenshots make it seem like Halion Sonic SE isn’t installed at all, like I suspected.

Try running the Steinberg Download Assistant and open the Halion Sonic SE 3 download folder:

Then run the installer directly from the folder that appears. Select the options to update or reinstall any existing components. See if you get any error messages.

1 Like

Ahh, This worked! Apologies, when you said reinstall previously I had only pressed “install again” & didn’t think to check the install folder. Everything is working now, thanks for the help :grinning:,