Drag-drop mono audio to create track - stereo FX do not work ?

OK, so this is a little weird. I have a mono WAV file. If I drag this into a new project it creates a mono track as expected and playing the project plays the audio. However, if I add an stereo effect in the insert slot it seems to be ignored. I tried it with the StereoEcho plugin and there was no audible echo of any sort. BUT … if I create a mono audio track using “Add Audio Track” then drag the same file onto the track everything works. I can add the same echo VST and it works perfectly. This seems to happen with all effects, I’ve tried with UAD, Softube, Waves etc including the stock Steinberg ones.

There are no differences in the settings or displays for the two tracks. Both are showing as mono, both play correctly but the one where I created the mono track by just dropping the file doesn’t use the effect. I thought at first it might be down to stereo effects just not working on a mono track, but they do work when added to a mono track that’s created using “Add Audio Track”.


Stereo effects work with Mono audio tracks in Cubase, but they’ll either automatically become a mono version of the plugin or only output the left channel (which by default is automatically centered). When working with mono tracks, you should use either group tracks or FX sends to apply stereo effects such as reverb and delay.

I tried reproducing your issue but the StereoDelay worked fine. This might have been a one time thing.

That’s strange, I can replicate it every time here, both the nonworking “drag-drop mono track to project to create a mono track” and the working “drag mono file to precreated mono track”. I’ll have to try this with Cubase 8 at some point, pretty sure I have it installed on a laptop somewhere!

Is this Cubase Pro, Artist or Elements?

And which OS?

Can’t reproduce here Pro 9.5.20, Windows 7 Pro.

Could you maybe create a sample project with one of each using a stock plug and just a short snippet of audio and upload it?