Dragged audio files in do not line up with each other

I’ve got a weird issue I’ve been running into where when I drag in a group of audio files into Cubase, most of them line up with the cursor however one of them imports to an earlier position. Not a huge issue but I was wondering what could be causing this so I know for the future. All the audio files were exported from the same session and should line up. I’m using Cubase 10. Thanks!

Have you opened the track up in the editor to see if the ‘start’ of the track (blue marker) is at the beginning of the track ?

Just checked and the snap point wasn’t at the beginning of the track, what could be causing that? I exported them all the same way but when importing to Cubase 10 it’s auto putting that snap point in a bar later.

Is there a way to stop this behavior and make the snap point the start of the track always?

Not if the start point was saved with the files , all you can do is import, save the files with the new start point and reimport . What program did you export them from ?

They’re all exported from the same version of Cubase, the same way by selecting the audio range with the “p” command and then exporting. Weird that one is different than the others. This seems to happen randomly when I export audio stems, sometimes the snap point is not at the start for whatever reason. Thanks for your help with this.

Ummm, strange as you say, i would just double check, move the tracks back 4 bars before exporting and see if any of them jump out of position, if not then export and check .

No worries , i’ll have another think

Even when changing the snap point for that one out of place file to the start manually and re-exporting again, when reimported it still auto sets the snap point ahead of the start

This is an old problem with Cubase. I don’t know when it started. The snap point is imbedded in the audio file. I don’t understand why Cubase haven’t introduced a disable button for the file snap so that grid and curser snap works with the truncated start of the audio clip like in the past. When copy and pasting or importing files one must constantly check the start point and correct it. A warning when importing files to position Often the file imports to before that position, clipping the start of the audio. If it is sync related the file will play ahead of the rest of the track. There is no quick way to fix this. Shifting the snap point has to be done one clip at a time. Changing the grid to “relative” does not fix this as some have suggested.
Has this been addressed in V12?