Dragging Range Tool does not Split MIDI properly even though "Split MIDI" is activated

Steps to reproduce:

  1. Enable “Split MIDI Events” and/or “Split MIDI Controllers” in Preferences.
  2. Create a MIDI part and add a single note that is 1/1 long (for convenience).
  3. Select Range Tool.
  4. Add a range that is positioned after the note start, but before the note end.
  5. Select “Split Range”
  6. Observe that the note it split into 3 notes with the MIDI part…
  7. Undo.
  8. Add the same range.
  9. Drag that range to the right.
  10. Observe that the note is only split in the parts that are not moved.

Expected behaviour: Range Tool should consistently split MIDI contents if “Split MIDI is activated”.

Actual behaviour: The Range Tool does behave consistently with the “Split MIDI” setting.

Oct-26-2023 15-23-22