Drastic ASIO spikes, can't seem to find a solution.

So I’m officially stumped.

Firstly my specs:
AMD 6100 Six-Core Processor
Nvidia GT640
20gigs of ram
1TB HD
Kontakt 5

I run a decent project. 5 Instances of QL spaces (reverb), full orchestra setup, about 14 gigs filled with Vst’s.
All Vst’s run through Kontakt. Preload Buffer Size in Kontakt is around 105 to give less stress to CPU and fill up more RAM.

I used a simple M-Audio Mobilepre MKII. Recently purchased a Forcusrite Scarlett 2i2, though this turned out to be worse.

About a month ago everything was going smoothly. I was still running on Cubase 5. Project was up, vst’s running without a hitch. Asio meter staying at a decent level. Been this way for a year or two.

Then one day I woke up and my computer was off. I turned it on and the monitor was not responding. It was hooked into the GPU through hdmi. I instead used a port on the motherboard which worked. Some drivers seemed fishy and my ASIO/Cubase project wasn’t running as good as before so I did a complete reinstall of Windows.

I loaded everything back up. Though when playing a project, within a couple seconds the Asio meter would max out. Clips, pops, the whole deal. Constantly. So, I bought a scarlett 2i2 thinking it might help my asio (even though my mobilepre did a fine job before the reformatting). This didn’t help and seemed to be worse.

I then chose to upgrade to Cubase 8. I was using 32bit Cubase 5 and using jbridge to be able to use 64bit plugins. I thought upgrading, and taking out the middle man of jbridge might improve performance. Though after loading everything up on Cubase 8, the meter was much worse. Even without playing anything, just with the project loaded up, the meter is about 15% filled, and slightly moving up and down. When playing the project, like before, after a few seconds the meter maxes out.

I did a bunch of the tips. Trying Asio Guard. Disabling it. Activating Multi-Processing. Deactivating it. So one and so forth. No luck.

I ran latencymon and saw a lot of problems with an Nvidia driver. I troubleshooted and fixed it. Though it still popped up. After a while, I just took out my the Nvidia gt640 from my computer. That didn’t make a difference either, though the nvidia driver from latencymon was no longer there.

I updated Bios. Didn’t help.

I made sure my computers power was on “high performance” in the control panel.

I have unhooked my harddrive and put it in another Sata connector on my motherboard. Didn’t work (this was a longshot).

I’ve ran Hot CPU and tested it. Tested came back fine. CPU is in good shape.

Ran disk check on harddrive. Some slight errors that were repaired, but that’s about it. Didn’t help either.

Anyone have any thoughts? A new reformat is always tough as you run into problems. The projects I’m running are a bit intensive, though I never had problems with this exact setup a few weeks ago. This is what stumps me. I mean, it has to be a hardware failure, right? But all diagnostics say that everything’s fine.

The “average load” and “real-time peak” max out. My cpu in task manager usually hovers around 50% when Cubase is playing the project.
Though it’s not a Cubase 8 issue, I believe. Because when I try with Cubase 5, the Asio meter maxes out too. I just can’t seem to find how everything changed so bad. A few weeks ago all my projects ran smoothly.

Confusing.

Thanks for the help!

Turn off record enable selected track in the preferences and make sure all you midi channels aren’t record enabled in your project. Also double check that direct monitoring isn’t turned on in the ASIO settings if you’re only editing.

I just removed all my preferences as per Steinberg support page instructions. I had to remove C7 & 7.5’s preferences as well, since C8 tries to rebuild from those…
C8 didn’t find my plugins upon startup, of course, but there was no spiking whatsoever anymore. Smooth as butter. Now I’m putting them back one for one and see where the issue is.
So: Have you tried “trashing the prefs”?

All the best,
Benji

Hey island,

Sadly, this didn’t help.

Keep in mind that Cubase 5 was running very smoothly a week or two ago. Though now, Cubase 5 and Cubase 8 are having insane asio spikes. I was wondering if it was some kind of driver issue, maybe somthing conflicting. Though I then reformatted and that’s didn’t do anything.

What kills me is all my hardware seems to be working fine.

I believe this is a direct result of their new asio 2.0 driver. Once you install 8.0, it rewrites the driver in your system. Now, even the older versions will run with asio 2.0…making it all crap out.


Jesus I’m frustrated: https://youtu.be/OHXqPoayo6k

maybe this will help, from another thread

http://www.steinberg.net/forums/viewtopic.php?f=226&t=78103#p446599