Driver 1.10.4 driver installer finishes immediately - driver not installed

I am trying to install Yamaha Steinberg USB driver 1.10.4, but when I run the installer (setup.exe), as administrator of course, the installer finishes immediately, and the driver is not installed. Details: I boot the PC into the administrator account, with my UR22 disconnected. I run the installer. I get the “welcome” screen of the installer, press “next”, accept the agreement and press “next”, and then, immediately, the “Setup has finished …” screen appears. When I (after another restart) attach my UR22 (directly to USB2 port, no hub), it shows up in the device manager as “other type”, with the little warning sign telling that drivers have not been installed.

The old driver has been uninstalled - although that also was quite troublesome. I ended up using a 3rd party uninstaller to get rid of it.

As a side note, I can install the 1.7.something driver listed under “old drivers” on the steinberg driver page. But of course I would like to use the new one.