driver selection problems

Hi, I have cubase 4ai and an alesis multimix 12 usb. When I use the asio driver that came with the mixer I can record no problem but have big latency issues trying to play back. ( as with directx asio driver )The yamaha kx series midi piano has undbearable delay. I tried asio4all and the piano plays almost without delay however I cannot use the microphone to record audio. It just doesnt pick it up.
So I change the driver back to the alesis one and it record audio.
To play back without stuttering I need to slect asio4 all again…sigh
There must be an easier way.

I’m not familiar with the Alesis Multimix 12 usb and have only a passing knowledge of ASIO4All, but here goes.

A few things:

  1. Can you adjust the buffer settings with the Alesis driver (via the control panel)?
  2. Have you enabled the mixer’s input in the ASIO4All control panel and set up your VST Connections accordingly?

Can you also post screenshots of your VST connections window and ASIO4All control panel please.

Hi Thanks for the reply.

Yes I can adjust buffer setting for the Alesis asio driver. although I have no idea what is a good setting !

You have the wrong driver setup in Device Setup!
Use the ASIO4ALL driver.

You need to have the ASIO4ALL driver setup right as well, do not have resample 44.1 to 48 set, USB audio codec looks wrong too, both should read 44.1KHz.

Refer to the ASIO4ALL documentation.

I have unchecked the box resampling.
Asio4all now loaded in VST audio system but I cannot get the mic to register still

Setup your input connections.

I have read the asio4all docs but not getting it it seems
How do I set up the inputs ?

i see the box has checked itself again when i restarted cubase !!

this is the control panel page. I have asio4all selected, Do I need to change the usb audio settings ? if so how


Go to the devices menu, VST connections and setup your inputs!

Hi again
I am not sure what has changed but now, after restarting after a short temper tantrum the mic will pick up, the piano will play without delay and it will all playback…Im sure it has been the result of your help and getting some basic setting correct.
Thank you very much for your time. To be honest I am quite amazed after struggling for days.

I have desperately recorded all the settings on the screen and the mixer so I can only hope I don’t screw thing up again lol


Great, and good luck :sunglasses: