Drum Editor changed?

Hi there!

Seems like my Drum Editor has changed. To the left I could click and see a text of the drum sound, for a example if its a kick or a snare… But now all that is gone?!?

I’ve tried clicking Everything where to add features (maybe I mis-clicked something and made this feature disseapear?) but to no avail so far…

Was this a stealth change to C10 Pro?

However, I’d like this feature back, it was nice, now I don’t know what the “dots” in the Drum Editor stand for and have to click them to listen if its a snare or a hi-hat, a kick, a tom, or whatever… Pretty annoying thing that this just suddenly disappeard like a week or so ago…

I’'ll attach an SS so you see whats missing to the left of the Drum Editor





Many Regards, Robin Gardner

My Drum Editor is fine, all the usual columns are present and functioning per normal. Can’t account for why you’re getting this.

Hi,

Try to Show/Hide Left Zone. Maybe this will fix it. If not, I would recommend to run Cubase in the Cubase Safe Start Mode.

Just noticed this:

“The number of columns in the list depends on whether a drum map is selected for the track or not.”+

https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/midi_editors/midi_editors_drum_editor_drum_sound_list_r.html

Yes…
I think all you have to do to “fix” this is load a drum map. How you return to the state of Robins attachment, I’m not sure. :question:

Hi,

This is true for the VST3 instruments only, right? Only if you use the function to show the sounds of the VST3 instruments. Or am I wrong?

I honestly don’t know. I just found that “Note” in the Operations Manual for Ver Pro 10 and thought it might help the OP’s issue with Drum Editor columns not showing.

Hi,

I was thinking about it again and really I don’t think, that if there is no map/no sound in the map, the whole panel would hide. I would say the panel would become empty.

Therefore I still think the solution is to trash Cubase Preferences.

No sure about the missing columns issue.

I said my Drum Editor was “fine,” however, I notice that, In Ver 10, the drop down to select which values – Drum Editor Column or Quantize Preset – is used.

Also now missing, in Ver 10, from the Drum and Key Editors are 1. Adapt to Zoon, 2. Use )Drum Quantize.

(Also, in “The Kit” the Open Hat at A#1 is mislabeled as Closed Hat.)

Hi,

Adapt to Zoom is hidden under the Grid Type (+|-) drop-down, same as Use Drum Quantize. And the last you are missing is probably Use Snap from Drum Map, which is also hidden under the same Grid Type (+|-) drop-down.

Have you found everything now?

Are you sure you are opening the Drum Editor not the Key Editor by mistake?

Hi,

The “Drum View” (the “diamonds”) are in the Drum Editor only. Same as the dedicated Stick tool. So the screenshot comes from a Drum Editor for 100%.

Hi! Thanks for trying to help out! Really Appreciate it!

I’ve tried about everything I can think of right now, except “Run Cubase in Safe Start Mode”. But that’s probably the last resort, but I’m getting there now, I guess…

I just updated to latest update (.15) just now… But that didn’t fix it…

I’ll attach a Picture from the manual where it shows how it used to look Before this “Drum Sound list”-column disappeard…

Unfortunately using “Ctrl+Shift+Alt” at start of Cubase 10 Pro didn’t work at all… According to the link it should give an option to delete program preferences. Instead I get a different window? I’ll attach a screenshot:
Cubase Safe Start Mode.jpg

Also another thing I just noticed, there’s an option in the Drum Editor that I can’t choose? It’s greyed out…

Maybe that’s the thing I’m after?

I’ll add a picture:
C10 Pro Drum Sound List.jpg

Hi,

Please, try the Safe Start Mode again. I believe this is the truck you need. To get into the Safe Start Mode, you have to press the combination immediately after double-click to the Cubase icon.

What you saw was an older Hub, which you can get if you hold down Shift (is I’m right) while start.

The menu option you get only if you are using VST3 Instrument.

Hi! Today I’ve revereted back to Cubase 9.5 Pro and all is back to normal with the Drum Editor, as you can see in the picture:

But I will try the “Safe Start Mode” again with Cubase 10 Pro, later on… Ty all! :smiley:

I don’t know what this is but…
I had this in Cubase 7.5…
I fixed it by
1… open the file on windows where the RAMP pre-sets are stored and possibly the other things like scripts and pre sets
(windows - users -your name-roaming- Steinberg ……etc)
open one at a time presss ctrl +A… then F5 then close that window and look for other folders that contain presets and or options scripts etc then repeat the last step.

1a … look for drum maps folder ….check if they are all there …if not re install them or copy from another Cubase setup if you have one or get them from my Steinberg/downloads…
press ctrl+A then F5 … close window.

2… in Cubase open up the drum program. Groove agent…load a kit , throw in a groove or make one internally clos and play

you hear sound ?? … good drag to arrange window … midi file showing ??..good go to the input chan selector for that track look for drum map ( pls note the old protocol was midi ch 10 used to open drm map automatically … I think it still does but not sure ).
look for drum map select GM Drum map… if it opens as you expect it great proceed to next step.
(if not you may have to dig deeper into step 1 )

3… use the make drum map from device or whatever its called … this is what I had trouble from whilst using BFD versions 2 and 3.
if this will mot work as expected then one of two things you have to check … copy and import the drum map manually or draw it in yourself … very tedious I know…
if this yields no results no need to panic just yet…

look to see if other Editors have the same or other display probs
if yes look into you gui setup or even look into graphic card driver.
if not then try step one with an even deeper look into files they are never easy to find at first…
you may have to trash the installation and start anew … complete register kill erase everything Steinberg Cubase etc and reinstall .
I have a similar problem whit the mixer not scrolling or displaying tracks after I use the three zones… I sorted this out by chaning the order of adding tracks to the mixer (if I did not track the project myself ) I sucks but worked eventually … what I mean to say is … just dig deep and you may get lucky…
I wish you luck …
pls post when you get it fixed as other users may be able to benefit from you woes .
cheers
T

ps…
copy your settings from 9.5 into 10
see what happens

Hi,

This should be done after the very 1st Cubase 10 start. And also after trashing Cubase 10 preferences folder (if there is Cubase 9.5 or Cubase 9 preferences folder.