Drum Editor problem with snap and GM drum map

Hello Gang,

I have 2 issues (Cubase 6.0.5 running 32-bit on Windows 7 64-bit platform):

  1. When i select a drum diamond in the drum edit window and try to move it to another snap point, the diamond jumps to the left of the desired snap point. Once I let go, it snaps to the desired snap point.
    In C5, it didn’t work this way. In C5 moving a diamond over the desired snap point locked into that point. Is this a bug or feature?

  2. Using HAL Sonic SE for a drum part. I can enter the notes in the piano roll editor but when I select GM drum map, no sounds are produced. This is not a problem with Groove Agent 1.

Any help is greatly appreciated.
Joey Daddario

  1. Make sure Snap isn’t set to Bar or Beat, you can set a Quantize value and set Snap to Use Quantize. Either that, or turn Snap off.

  2. Use No Map for that plug.

Hi MM,

Thanks for the quick reply.

On the first issue, I made sure all of those conditions you pointed out were in place…but unfortunately the problem is still there. When I drag a diamond, it temporarily snaps just to the left of the snap point until I release the mouse button, Then it snaps to the intended snap point.

On the second issue - yes of course using No Map will allow the sound to come through but i really wanted to use the drum editor for HAL Sonic SE as i was using a Drum patch. Darn. i don’t remember this being an issue in early C5 release.

I sent a trouble ticket into the Steinberg. I’ll post the reply here when I get it.
Again thanks,
joey Daddario

I never noticed that “jump to the left” issue until now, I expect it’s just something I’ve got used to. Nonetheless, it seems to be less noticeable the more you are zoomed in so perhaps you could try that?
With regards to the drummap, have you selected the correct Channel (“Chan”) and “output” in the drum editor? (Across the top there are columns for “Mute”, “Instrument”, “Pitch”, “I-Note” etc. and there should be one called “Chan” and another called “Output” - Going on my own experiences, it’s most likely to be the wrong output selected. Apoligies if I’m not making sense, I find it a bit tricky to explain these things :slight_smile: .
Edit: Where mashedmitten says “Use no map for that plug” perhaps he meant select “Not connected” in the “Output” column in the drum editor - this should use the instrument assigned to the midi track (assuming you have one selected).

Thanks for the reply Steve. Though your suggestion wasn’t the answer, I was motivated to keep digging. And I found the solution to getting the GM Drum Map to to work with HAL Sonic SE. Now i can use the Drum Editor like I want when I’m using a Drum patch on the Sonic.

Solution: Choose Drum Map Setup from the Drum map pulldown on the main arrangement window. Highlite GM Map if it isnt alreay hilighted. Go to the column titled Channel. Click the first drum (at the top of the column) - usually the Bass drum. While holding the mouse down, press the CNTRL key and select ANY. All the number "10"s will change to ANY. Now when you choose GM MAP in the drum maps, all the drums in that Instruments patch will play in the drum editor.

Hope this helps. As it turns out the process is “sorta discussed” in the Operation Manual page 401 under The Channel And Output Settings.

Let me know if this works for you. I’m curious.
Thanks again all.
Joey Daddario

Yep, it does indeed work just as you said when I use an “Instrument track” (The channels all default to chan 10).
Although I usually set up the track from “Devices>VST Instruments…” and then create a midi track separately. This way (on my system at least) the channels seem to automatically default to “Any”. Oh, and I was just thinking about your first issue (drum diamonds snapping to the left until you let go) - perhaps it’s a feature which allows you to see if you are about to drop a diamond directly on top of another one? It’s not a brilliant “feature” admitedly, but I can sort of see why it would help on the odd occasion. Anyway, glad to see you’ve sorted your issue.