Drum Map - Midi Keyboard lag issue

I Create an empty project
I load Groove Agent SE and choose the option “Create Midi Track”
I load a kit in Groove Agent SE
I play on my Midi keyboard - It works fine
I create an event on the created Midi track
I play on my Midi keyboard - It works fine
In the Inspector I choose “Create dum map from instrument”
I play on my Midi keyboard - It works fine
I double click the event I created to open the drum editor
I play on my Midi keyboard - NOW THERE’S A SERIOUS LAG! (roughly equivalent to my largest buffer setting - 2048 samples)
I close the drum editor
I play on my Midi keyboard - The lag is still there
In the Inspector I disable the created drum map by choosing “No Drum Map”
I play on my Midi keyboard - The lag is still there
I double click the event to get in to the Key editor.
I play on my Midi keyboard - THE LAG IS GONE!

Help anyone?

I had a similar thing happen, and I trashed all the preferences for Cubase 8 and everything worked again, it’s s real bummer what your going threw, I also had wired like note repeats as well, hope this helps

Here to…since december 2014…
https://www.steinberg.net/forums/viewtopic.php?f=234&t=71913
…and still no answer. So at first I thought this would probably be a OS X related problem.

i can confirm this issue.

When asio guard is active and a drum map is used on an instrument track it causes monitoring delay. Gets worse the higher asio guard is set.
I also found that if you route a second midi track to the instrument without a drum map on this midi track and selecting the midi and instrument track alternatively while playing you will notice that once you selected the miditrack without the drummap the latency is gone. As soon as you select the intrument track with drum map applied lag is prominent. Once you turn off Asio Guard there is no additional latency on both tracks

I also found that drum maps cause midi notes to record earlier.
I have an instrument track with drum map and a second miditrack routed to the same instrument track. both track uses the same midi input deviece. When i now record simultaniously on both tracks midi notes on the intrument track with drum map are recorded earlier. this is weired because according to the monitoring latency i would have expected it the other way round.

this is consisten on two different computers and in can reproduce this in C Pro 8.5.20 and C Elements 8.0.40 on win7 64bit


I would appreciate if someone from steinberg could check this

thanks

Did anyone come with an answer for this? Other than not using a Drum Map which is less than ideal?

Thanks.

Yes. Turn of Asio Guard for the instrument specifically or if possible globally.