Drum note beaming total chaos

Hello first of all.
I don’t know if this is the right place to post this; if not, please point me in the right direction. I… I don’t even know how to search for a solution…

I am making an arrangement for drums using Dorico Elements (3.5), and I ran into massive issues with beaming. I want something like this (4/4 measure):


And I currently have:
Bildschirmfoto 2021-01-07 um 15.22.22

The K. Dr. 1 and Fl. Tom. 1 were beamed together before, but the H-Hat and Fl. Tom 1 wouldn’t align vertically, so I set the Fl. Tom 1 beam direction up in the Edit Percussion Kit menu, which caused the first beam to “break” (=have a gap) too. Second one is somehow always broken.

These pauses are also annoying. I tried to select them all and apply Edit > Remove Rests, but that failed.

The song is made from scratch, no XML or other imports. If you want to take a look on the project yourself, I can upload the file too (just say me what format, i.e. a dorico file or zipped).

I hope somebody can explain what’s going on, and thanks in advance for any kind of help.
Cheers!

If you want some tom stems to point down and some to point up, you will likely have to create duplicate tom s in your kit, one version with stems pointing up and one with stems pointing down.

Dorico operates under the impression (convention) that either players will expect drums to have down stems and cymbals to have up stems or foot operated traps to have down stems and hand struck traps to be up stem. It doesn’t count on the same trap having both up and down-stem versions, so if you want that (or the foot/hand division), you have to adjust the kit.

I created another Fl. Tom. with the opposite stem direction, but this doesn’t solve beaming issue. Instead, it removes the sixteenth and eighth rest below and turns the sixteenth above to a quarter rest. The gaps remains.

It looks as though you’ve been attempting to fix the beaming manually, from Edit (or right-click) > Beaming > whatever. You probably need to select the passage and go Edit > Beaming > Reset Beaming, in order to let Dorico do the right thing automatically.

Resetting beams doesn’t change anything :confused:

I suspect we’re taking you down a fruitless path, here, because you have a bigger problem with the inability to hide rests (which Dorico can’t currently do on percussion kits, seeing as percussion kits effectively condense multiple single staves and pad with rests automatically).

Try going Notation Options > Percussion > Voicing for drum set kit presentation: Use single voice.

I find that using the stock basic drum set and that Notation Option, I can get your desired result pretty easily:

1 Like

This seems to work, so I’ll mark it as the solution. Sadly this is a Dorico Pro solution, so I guess Elements users have to live with that. Thanks for your time!

You should be able to achieve the same result by putting every instrument in the kit in Upstem Voice 1, in the Kit Editor.

I’m not sure if I understood that correctly, but in the Kit Editor I set the stem direction from every note up. It removes all the unwanted rests, but the beaming is still the same.

There has to be some sort of override going on, because Dorico won’t do partial beams like that by default.

My suspicion is still that you have selected single notes and gone Edit > Beaming > Beam Together, which tells Dorico to beam that note to itself. I can’t think of any other way that Dorico would give you this nonsensical beaming.

Please select the whole passage again and go Edit > Beaming > Reset Beaming.

Sorry, but resetting beaming changes nothing. At this point I will upload the dorico file, maybe something in my project is corrupted or something.
Baby I’m Yours_Drums.dorico (421.8 KB)

This is very puzzling. If I type the contents of bar 8 into bar 7, manually, I get the correct result, indicating that there’s nothing intrinsically wrong with the project settings. None of the usual tricks (Reset Beaming, Reset Appearance) seem to make any difference to the existing material, though.

Is this a native Dorico project, or did you import the notes in via MusicXML or MIDI?

Interesting… As said in the original post, it is a native Dorico project. No imports.

I’ve just experimented a little bit further with a new project.

If I manually alter the beaming, then go into the Kit Editor and alter the voices/stem directions of those instruments, the beaming commands no longer work.
If I go back to the Kit Editor and switch the voices back to the way they were before, the beaming commands still don’t work.

Your best bet is probably to reinput the few affected measures.

Weird… Is is buggy behavior, right? Should I add an issues tag? I re-inputted the notes, and everything works fine now. Thanks again for your time!

I suppose so. I have to admit this one’s new to me, so I’ve added the issues tag :slight_smile:

1 Like