Drum parts: Problem with ghost pauses that can't be removed

In one of my flows, I get “ghost bar pauses” that can not be removed the normal way (Edit > Remove rest).
The seem to appear when I’ve had an drum-instrument with stem direction up (for example Ride cymbal) and then want to write a bar with only stem direction down instruments (for example toms).
ghost-pauses.png
As said, I can’t use Remove rests to delete them, nor Ends voice in the properties panel.
(I guess that this is caused by the notation engine handling voices in drum parts somewhat differently than in normal instruments parts.)

Is there a way to get rid of these pauses?

Switch on View / Note and Rest colours / Voice colours, so you can see what voice they belong to.

There will be some way to get rid of them, but just looking at a picture of two bars with everything printed in black doesn’t give much useful information!

https://www.steinberg.net/forums/viewtopic.php?t=139112

Thank you, Rob and Pianoleo!

If I get Daniels answer right (https://www.steinberg.net/forums/viewtopic.php?t=139112), there is currently no way of getting rid of these pauses. And they can’t be changed in size or color either. Let’s hope that this bug can be cleared out pretty soon!

Edit: Actually, I was able to get rid of the redundant pauses by adding a new instance of the same instrument to the same line in the Kit editor, and setting the new instrument to voice # 2. Rather messy, and requires quite a lot rework, but it works!

hello, I’m having the same issue here, but I can’t make this work.
I’ve tried “Default Stems Up”, “Change Voice to next voice on staff”, and “Swap voice order” but it doesn’t seem to do anything.
Any idea on how I could hide these weird rests in voice 1 of this drum set part?

I should mention that “do not pad voice with rest” is on in the notation options

I ended up selecting “Use Single Voice” in Notation Options>Percussion and that worked for me!