drum set won't play back properly (resolved)

Attaching two files.
The one labeled “drum set works here” works. This was originally a midi file that I opened with Dorico.
The other one labeled BOY is the actual piece that when I copied the drum track from “drum set works here” to, only the whistle plays back for all notes.
I even made sure that the BOY file has drums assigned to channel one in the PLAY menu (like in the drum set file). But still I only get the whistle.
Additionally, all the different instruments included in the GM drum kit play back perfectly via my midi keyboard. Just the notated drum set track is all whistles.
Please help me understand what’s going on.
Drum set works here.dorico.zip (544 KB)
BOY (for Steel Pan Band).dorico.zip (1.49 MB)


I don’t know how this happened or why, but I looked into your endpoint setup: there is no Percussion Map specified. Just choose GM Drum Kit as Percussion Map and voila, all the drums are there.


I found the percussion mapping under the PLAY menu, but it seems it’s mapped? Here’s a snapshot.

Anyway, it’s still not working. Just a bunch of whistles. I’ve checked everything. Multiple times.

Not quite,

you have to open the endpoint setup in play mode…

Double click the percussion map and choose GM Drum Kit. Hit OK.

Yes, now it works. Thanks!