Drum track midi problem


I’ve recently upgraded to Cubase 10.5 and I’ve realized a problem that I cannot find solution. I’m working with EZ Drummer and when I open a midi editor to edit a midi track, the grid doesn’t change as requested. I’m trying to change the grid to triplets, but it remains in sixteenth notes, although it really quantizes to triplets! In this track I’ve selected a Drummap from Ez Drummer. Maybe that has something to do with it, as the rest of the tracks work perfectly (and doesn’t have a selected any GM Map).

Also, there’s a small issue that might be great to get solved. I constantly use the drum track with a drummap, and it helps the working process in my band while writing music to visualize it that way, but, when the track is not selected, the drummap doesn’t apply. I need then to close all midi editor screens I have opened, select the track, and then open the editor with the appropriate Drummap.

Let me know if there’s something I can do or if this is something that needs to be fixed :slight_smile:


Moe Espinosa


In the Drum Editor, you can set Snap for every single Pitch (Drum). On the right side of the Snap Type (Grid), you can see -|+ button. Here, you can set the Grid Type. Make sure it’s set to Use Quantize (and the button is disabled). The default setting is Use Snap from Drum Map. Then the Grid follows the Drum Map Snap.

Regarding your second question… In the Lower Zone click to the Editor arrow and select the editor type you want to use: Key Editor / Drum Editor / Score Editor. Btw, the editor type should change automatically, when you switch between a MIDI Part on the track with a Drum Map and a MIDI Part on the track without a Drum Map.

Hi Martin!

My problem with the grid is not with the snap function. It’s actually curious that when I put the grid in triplets, the grid shows in sixteenth notes, but actually quantizes to triplets! Of course, I end up quantizing and editing my midi to the correct grid, but not being able to see the lines is really annoying and when it comes to writing rhythms, it helps to visualize it (as if it were a score).

Regarding my second question, I see that, exactly as you mentioned, when I work with the lower zone editor, it changes as requested, but the problem is that I have that option dissabled, because I don’t like having such a small editor, and I like that when I edit a midi track, double click action will open a new window. So, when I have a key midi window opened, if I don’t select first my EZ drummer instrument track, and I open the midi track of that drum track, it opens as a key track, not a drum track. Then I have to close all my midi track editor windows, select the EZ drummer instrumental track, and then it opens as a drum track with my selected GM Drum track.

I bet that a video would be more self explanatory than me trying to find the words to explain myself! hahaha

Thanks in advance! :slight_smile:


So, how is your Grid Type set up? Is it set to Quantize and the Grid Type button is enabled?

There is no “MIDI Editor”. There are multiple editors in Cubase. There is dedicated Key Editor, which shows the Keys and there is Drum Editor, which shows the diamonds. So if you open the Key Editor, it doesn’t matter what MIDI Part do you select then. The Key Editor is alway showing the data the “Key Editor-way”. If you open the Drum Editor, it will always how the data the “Drum Editor-way”, whatever MIDI Part do you select.

But there is an intelligence in Cubase, so if you double-click to the MIDI Part to open an editor, Cubase decides to open Key Editor (if there is no Drum Map assigned) or Drum Editor (if there is Drum Map assigned). But this works only when you open a new editor.

Cubase doesn’t`t close and reopen other editor while selecting new MIDI Part.