Drums notation problem

Hi guys!

I’m having some problems with creating a drums part, where Dorico is adding rests I can’t remove. Why is it putting a whole bar rest and how can I turn it off?

Some help would be greatly appreciated!!

Dorico’s putting in a bar rest there because you’ve presumably got more notes in the up-stem voice for the kit later in the same part. Make sure you have ‘Rests at start and end of voices in five-line percussion’ set to ‘Do not pad voice with rests’ on the Percussion page of Notation Options.

Hi Daniel,
I did set it to do NOT. It’s really strange and also inconsistent. A few bars later the rests are gone but the notes are the same

It will depend whether or not there are any more notes in the up-stem voice later in the part.

Obviously the fact that you can’t easily edit rests on percussion staves in the same way you can on pitched staves is something of an impediment, and something we will certainly be addressing as soon as it’s practical to do so.