DSI Tempest as an external instrument

Hi,

I am trying to set up the Tempest drum machine by Dave Smith Instruments as an external instrument in Cubase 10. However, I’m hearing double triggers when playing the instrument. I’m pretty sure that I’m setting up everything as described in the manual and that I shouldn’t hear double triggers, but it happens anyway. Here is my setup:

  • This is with Cubase Pro 10.0.30.


  • The Tempest is connected via USB MIDI to my Mac.


  • The audio output is connect to a Keith McMillen K-Mix, which is then connected to the Mac via USB audio.


  • I have set up the Tempest as a MIDI device.


  • In Audio Connections, I have created a Tempest instrument using the corresponding K-Mix audio channels as its device port. (In my case, Analog 3 and 4.)


  • In general preferences, I keep MIDI Thru Active deactivated, and VST Auto Monitoring at Manual.


  • When adding a track with Tempest as the instrument, I don’t activate monitoring.


  • Local Control on the Tempest itself is set to on.

With that configuration, I hear double triggers when playing drums on the Tempest. When I record some drums, I still hear double triggers when playing the recording back. However, when I perform a “Render In Place”, the double triggers are gone in the resulting audio (they are also gone while the rendering happens).

When I switch Local Control to off on the Tempest, I hear nothing. With Local Control back to on, if I then go to the Audio Connections in Cubase and set the return gain to negative infinity, I don’t hear double triggers anymore. However, then I cannot use Render In Place anymore because it doesn’t get any signal to record.

I’m very confused by this situation, because I thought that manual monitoring would allow me to ensure the audio is not monitored. However, it seems I must be missing something.

What am I doing wrong?

Thanks,
Pascal

Hi,

Shouldn’t this be set to off?

Hi,

The local control setting is not the problem here. If MIDI Thru Active is disabled in Cubase, this doesn’t cause double triggers. You can also set local control to off and enable MIDI Thru Active, but I prefer the lower latency when local control is on.

In the meantime, I finally figured out what the issue was: The problem was how the K-Mix was set up. In the K-Mix Editor, you can change how the USB audio input and output are routed. By default, if USB Output is set to “post”, the K-Mix combines its physical input with the audio coming from the computer. This is where the double triggers came from. If I set USB Output to “pre”, then everything is fine. Phew. :wink: (I missed this before because the K-Mix manual is a bit confusing in its description about these settings.)

Thanks a lot indeed anyway for caring to think about this issue.

Pascal

Hi,

Yes, I was thinking it should work with Local Control On and MIDI Thru disabled, but…

I’m glad you found a solution.