dspMixFx - update the UI - please before I go blind

I recently started using dspMixFx with Logic Pro X on a 4K monitor. Most of Logic is rendered beautifully on the monitor. I am using the dspMixFx with my UR44 and although it works perfectly, the UI looks really dated when used with Logic on a 4K display. I WAS previously using the UR44 with Cubase 8.5 where it is integrated and there was no independent program/UI. But as a stand alone program (dspMixFx), it really could use some modern UI attention.

All that aside, I really enjoy using the UR44 with all of its function is the same place (dspMixFx). This same function as implemented in Cubase is crazy bad - who ever came up with the strange slider widget in the mixer. There are too many separate dialogs to make other changes to the unit.

Sorry if this sounds like a rant. I really love the UR44 - but just want to visually see it better on my monitor and when using Cubase I would like to go to one place to make my adjustments to the device.

Thanks for listening - John

1 Like

Similar problem here on windows 8.1 with 4k display, the dspMixFx window is very small.

Yes. Please make the mixer readable with high DPI displays.

I’ve suggested an update to the UI in the past, but it seems Steinberg likes how it is now. Yet, it looks a lot like an amateurish open source project, not very well integrate in the system (clicking on a scrollbar, for example, only scrolls by a single channel, not by a page).

I’ve sometimes thought about purchasing a Focusrite or a MOTU, just to use that beautiful software, and only use the UR824 as an expander connected via ADAT. Luckily, dspMixFx is only to be used for remote setup, and then be hidden to the eye.

Paolo

Finally I found a solution for this problem.
Maybe this option comes with the windows 10 anniversary update.
So if you have the latest windows version go to your “C:\Program Files (x86)\Steinberg\UR44” and right click into the context menu of dspMixFx_UR44.exe. Here go to compatibility tab and set the dpi scaling to system.
This works for me using a 4k monitor with 200% zoom.

1 Like